Bug 1268557 - libusb collision if google-chrome repo used
libusb collision if google-chrome repo used
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libusb (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-03 00:44 EDT by Richard Jasmin
Modified: 2015-10-03 04:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-03 04:05:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Jasmin 2015-10-03 00:44:38 EDT
Description of problem:
As part of trying to give users of my spin an option, I used the instructions on if-not-true-then-false. The problem is that the keys for google-chrome mismatch with the libusb files. Once installed, the repo will not uninstall and it overrides the libusb specs.Thereby libusb cannot be reinstalled, nor removed.

Installing from sources accomplishes nothing.

And I couldve sworn Ive dropped this bug before.

And as always, the free alternative is around, chromium.Some forum googling found the two lines to get this installed:

(as sudo)
 dnf copr enable spot/chromium
 dnf install chromium

However, for some reason, spot never shows in the repo list.

I would recommend blacklisting the official google chrome repo for the time being.It, like korora produces an unfixable situation.One can always manually install the app and its key, as I have done with libdvdcss and a few other minor packages.

Multiple apps break with the libusb issue.

Version-Release number of selected component (if applicable):
detected in 22

How reproducible:
on repo initial installation and useage.

Steps to Reproduce:
1.install google-chrome repo as specified on the aforementioned website
(just dont install google-chrome)


Additional info:
Yes, I know this is mostly non-free, but breakage like this should show either what NOT to do/use or we should have a workaround somehow.We can list bad repos like we do for EL somewhere.
Comment 1 Hans de Goede 2015-10-03 04:05:44 EDT
(In reply to Richard Jasmin from comment #0)

> And I couldve sworn Ive dropped this bug before.

Yes you've and I've closed it, because there is NOTHING we can do to fix issues with 3th party repositories. If google's chrome repository is causing issues for you, you must go talk to Google, instead of filing bugs with Fedora, because there is NOTHING we can do about this.

Note You need to log in before you can comment on or make changes to this bug.