Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1268606 - "dnf install" exits if there is a non existing package in the requested packages list
Summary: "dnf install" exits if there is a non existing package in the requested packa...
Keywords:
Status: CLOSED DUPLICATE of bug 1197456
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-03 14:48 UTC by Germano Massullo
Modified: 2015-10-05 09:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-05 09:59:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Germano Massullo 2015-10-03 14:48:25 UTC
Description of problem:
If you run
# dnf install a b c
where a and c are packages that exist in active repositories and b is a package that does not exist,
dnf will exit ignoring the other packages and returning message:

No package b available.
Error: Unable to find a match.



Version-Release number of selected component (if applicable):
dnf-1.1.1-2.fc22.noarch

Additional info:
Bug affects Fedora 23 too.

Comment 1 Honza Silhan 2015-10-05 09:59:06 UTC

*** This bug has been marked as a duplicate of bug 1197456 ***


Note You need to log in before you can comment on or make changes to this bug.