Bug 1268607 - SELinux is preventing chronyd from using the 'chown' capabilities.
SELinux is preventing chronyd from using the 'chown' capabilities.
Status: CLOSED DUPLICATE of bug 1259636
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:60325106618251bb04243d692f5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-03 11:35 EDT by Nicolas Mailhot
Modified: 2015-10-05 17:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-05 17:02:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2015-10-03 11:35:28 EDT
Description of problem:
SELinux is preventing chronyd from using the 'chown' capabilities.

*****  Plugin catchall (100. confidence) suggests   **************************

If vous pensez que chronyd devrait avoir des capacités chown par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep chronyd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:chronyd_t:s0
Target Context                system_u:system_r:chronyd_t:s0
Target Objects                Unknown [ capability ]
Source                        chronyd
Source Path                   chronyd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-150.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.3.0-0.rc3.git2.2.fc24.x86_64 #1
                              SMP Wed Sep 30 15:23:07 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-10-02 20:30:25 CEST
Last Seen                     2015-10-02 20:30:25 CEST
Local ID                      c4d03e3d-f835-4d23-bcd5-270531ca4479

Raw Audit Messages
type=AVC msg=audit(1443810625.768:777): avc:  denied  { chown } for  pid=21804 comm="chronyd" capability=0  scontext=system_u:system_r:chronyd_t:s0 tcontext=system_u:system_r:chronyd_t:s0 tclass=capability permissive=1


Hash: chronyd,chronyd_t,chronyd_t,capability,chown

Version-Release number of selected component:
selinux-policy-3.13.1-150.fc24.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.3.0-0.rc3.git2.2.fc24.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2015-10-05 17:02:18 EDT

*** This bug has been marked as a duplicate of bug 1259636 ***

Note You need to log in before you can comment on or make changes to this bug.