This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 126861 - Missing socketmap support
Missing socketmap support
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-28 10:50 EDT by Petr Krištof
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-09 10:37:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sendmail-socketmap.patch (642 bytes, text/plain)
2004-06-28 10:51 EDT, Petr Krištof
no flags Details

  None (edit)
Description Petr Krištof 2004-06-28 10:50:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Redhat package of sendmail 8.13 is missing new long awaited
and must have feature "socketmap" support.

It alows near cooperation with cyrus-imapd and many more
generaly functions.


Version-Release number of selected component (if applicable):
sendmail-8.13.0-1

How reproducible:
Always

Steps to Reproduce:
 

Additional info:
Comment 1 Petr Krištof 2004-06-28 10:51:29 EDT
Created attachment 101466 [details]
sendmail-socketmap.patch

Very simple patch for .spec file to enable compile option.
Comment 2 Thomas Woerner 2004-09-09 10:37:11 EDT
The inclusion of socketmap in sendmail would require perl and the
reuirements of perl as additional requirements for sendmail. Perl is a
really big package and socketmap support can not be in a subpackage of
sendmail, because it has to be compiled in sendmail directly. 

Therefore it does not make sense to include socketmap with the current
perl server and client.

Closing as "WONTFIX" for now.
Comment 3 Kenneth Porter 2004-09-27 13:29:20 EDT
The socketmap client is implemented in C. The example client and
server supplied in the package require Perl, but I don't believe
examples should affect the package requirements. They should be
treated as documentation.

The "real" implementation:
http://www.sendmail.org/~ca/email/patches/sendmail-8.12.7-socketmap-v4.patch

The examples:
http://www.sendmail.org/~ca/email/patches/socketmapServer.pl
http://www.sendmail.org/~ca/email/patches/socketmapClient.pl

The example client is used to test actual servers and would only be
used for development.

Another possible application is to store maps in one's favorite DB
(eg. MySQL, PostgreSQL), allowing the DB code to live in a separate
process/package.
Comment 4 Thomas Woerner 2004-10-26 09:03:39 EDT
Fixed in rawhide in rpm sendmail-8.13.1-2.1 or newer: Now with
SOCKETMAP support.
Comment 5 Petr Krištof 2004-10-26 09:18:58 EDT
This allow sendmail/cyrus-imapd to verify local recipient's existence
before accepting email.
Great for antispam defension.

Thank you very much.

Note You need to log in before you can comment on or make changes to this bug.