Bug 1268624 - Corner case where lxdm allows the login even if the provided password is wrong
Corner case where lxdm allows the login even if the provided password is wrong
Status: CLOSED DUPLICATE of bug 1271377
Product: Fedora
Classification: Fedora
Component: lxdm (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-03 17:58 EDT by Giulio 'juliuxpigface'
Modified: 2015-10-13 15:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 15:51:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio 'juliuxpigface' 2015-10-03 17:58:45 EDT
Description of problem:
I found what seems a corner case where lxdm allows the login even if the provided password is wrong. This might not be a true bug, but in my opinion the behavior of lxdm in this situation is somehow strange.

Version-Release number of selected component (if applicable):
lxdm-0.5.1-6.D20150806git17ac3772.fc23.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create an user without password.
2. Login through lxdm with that user.
3. Provide a password for the login.

Actual results:
lxdm allows the user to login.

Expected results:
In my opinion (but I might be wrong), lxdm should refuse the login. The real password is blank, so if no blank password is provided, the real combination of "login name + password" is not actually matched.

Additional info:
Fedora 23 Final TC1 (x86_64) on qemu-kvm.
Comment 1 Rex Dieter 2015-10-13 15:51:45 EDT

*** This bug has been marked as a duplicate of bug 1271377 ***

Note You need to log in before you can comment on or make changes to this bug.