Bug 1268654 - [RHEL7] systemd: all processes in scopes (including user sessions) SIGKILLed immediately on shutdown with no opportunity to shut down cleanly
[RHEL7] systemd: all processes in scopes (including user sessions) SIGKILLed ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: systemd-maint
qe-baseos-daemons
:
Depends On: 1170765
Blocks: 1139380
  Show dependency treegraph
 
Reported: 2015-10-04 08:03 EDT by Jiří Dostál
Modified: 2015-12-07 07:05 EST (History)
43 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1170765
Environment:
Last Closed: 2015-12-07 07:05:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiří Dostál 2015-10-04 08:03:16 EDT
Cloning for RHEL7 bug fix request

+++ This bug was initially created as a clone of Bug #1170765 +++

Description of problem:

I have been noticing during F21 cloud and atomic testing that I sometimes lose my bash history. This seems to be triggered by reboots as can be shown below:

[root@f21 ~]# cat .bash_history | wc -l
2
[root@f21 ~]# history | wc -l
123
[root@f21 ~]# reboot
Connection to 172.24.4.228 closed by remote host.
Connection to 172.24.4.228 closed.
[root@localhost ~(keystone_admin)]# 
[root@localhost ~(keystone_admin)]# ssh -i key1.pem
fedora@172.24.4.228
Last login: Thu Nov 20 18:54:48 2014 from 172.24.4.225
[fedora@f21 ~]$ 
[fedora@f21 ~]$ sudo su -
[root@f21 ~]# history | wc -l
3


Version-Release number of selected component (if applicable):

This is from the F21 Cloud RC5 image:

[fedora@f21 ~]$ rpm -q systemd
systemd-216-12.fc21.x86_64

How reproducible:

Seems to be pretty consistent to me. 

Steps to Reproduce:

See description.

Actual results:

My bash history is not saved. 

Expected results:

My bash history is saved.


Additional info:

I think this is an issue with systemd but it could be some other component. Feel free to re-assign where appropriate.

+++++++++++++++++

Hello,

I've created this BZ in order to request a fix for the bug described above. I'm facing the same issue on RHEL7. 

More detailed - There is a feature in Satellite 5 that allows you to execute shell command on remote machine via WebUI. Then you can check status of the command - Pending/Picked Up/Failed/Complete ... When you execute "shutdown -h now" via remote command, the machine shuts down immediately and does not have a chance to report back to server. This results in bad command status and might even cause shutdown loop. Original Satellite 5 BZ https://bugzilla.redhat.com/show_bug.cgi?id=1260527)

Using systemd-219-17.el7
Comment 2 Lukáš Nykrýn 2015-10-05 06:35:30 EDT
That can't be the same issue. We have reverted the patched which caused this in rhel. Can you reproduce it and provide shutdown log? https://wiki.freedesktop.org/www/Software/systemd/Debugging/

Note You need to log in before you can comment on or make changes to this bug.