Bug 1268667 - sddm, lightm, and lxdm: Incorrect resolution after logout (qemu-kvm guest)
sddm, lightm, and lxdm: Incorrect resolution after logout (qemu-kvm guest)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice-vdagent (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christophe Fergeau
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-04 09:14 EDT by Giulio 'juliuxpigface'
Modified: 2015-10-17 05:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-17 05:30:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio 'juliuxpigface' 2015-10-04 09:14:51 EDT
Description of problem:
After loggin out from a desktop session, the resolution changes and it's impossible to revert it. It's also impossible to reach some buttons of the GUIs. Mouseclicks doesn't also work properly.

I've encountered this with various login managers (kde's default one, xfce's default one and lxde's default one): the only one exception is gdm, which resizes correctly after the logout.

Version-Release number of selected component (if applicable):
spice-vdagent-0.16.0-1.fc23.i686

How reproducible:
- Always (with sddm, lightm, lxdm)
- Never (with gdm)

Steps to Reproduce:
1. Start an installed qemu-kvm guest with virt-manager.
2. Log in to a standard desktop session.
3. Log out.

Actual results:
The resolution doesn't fit all the GUI.

Expected results:
The resolution should contain all the GUI.

Additional info:
I'm pretty sure that this is a regression of a component (not sure if it's spice-vdagent fault, though), because I remember that logout was working fine during the F22 testing cycle.
Comment 1 Giulio 'juliuxpigface' 2015-10-17 05:30:00 EDT
Closing this as I can't reproduce the issue with 'spice-vdagent-0.16.0-2.fc23'.

Note You need to log in before you can comment on or make changes to this bug.