Bug 1268689 - window-list unresponsive if extension menu is opened
window-list unresponsive if extension menu is opened
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks: 1297830 1313485
  Show dependency treegraph
 
Reported: 2015-10-04 15:09 EDT by rudolf
Modified: 2016-11-03 21:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:41:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 748919 None None None Never

  None (edit)
Description rudolf 2015-10-04 15:09:58 EDT
Description of problem:
window-list does not respond to mouse clicks after moving mouse pointer from opened extension menu.

Version-Release number of selected component (if applicable):
Name        : gnome-shell-extension-window-list
Version     : 3.14.4
Release     : 9.el7

How reproducible:
always

Steps to Reproduce:
1. open some window and minimize it
2. open some extension menu i.e. workspace switcher and leave it open
3. move mouse pointer over minimized window in window-list and click on it

Actual results:
- window will show only after multiple (sometimes 5 or more) mouse clicks
- right-click dialog menu does not work

Expected results:
First mouse click should close opened menu and 2nd should un-minimize window.

Additional info:
Bug has been reported upstream
Comment 2 rudolf 2015-10-04 16:27:21 EDT
Correction to Expected results:

- Window should show after first mouse click
- Ditto for right mouse button dialog
- Ditto for workspace switcher if we are moving from top bar menu
Comment 4 Matthias Clasen 2015-10-05 14:03:34 EDT
The expected result is that the first mouse click dismisses the menu, and the second mouse click activates the workspace switcher button. The fact that it doesn't indicates that the workspace switcher is missing an enter event that should be generated when the grab from the menu goes away.
Comment 5 Matthias Clasen 2015-10-05 14:07:18 EDT
this needs to be fixed upstream first
Comment 7 rudolf 2015-10-07 14:29:25 EDT
Patch is available upstream. It also fixes same problem in Frippery panel favorites, and probably in ALL extensions using St.Button
Comment 8 rudolf 2015-10-15 16:35:18 EDT
Any chance to make it blocker bug?
Even if it's not regression, this behavior is present in too many extensions and parts of gnome-shell, and it's pretty annoying for users coming from RHEL6 / GNOME 2
Comment 9 Florian Müllner 2015-10-16 08:22:39 EDT
(In reply to rudolf from comment #8)
> Any chance to make it blocker bug?

Feel free to ask for it by setting the blocker? flag, but I wouldn't get my hopes up too high - it's hard to argue that the issue is critical, plus the number of users who were annoyed enough to take it to bugzilla is very small (two users on an upstream report for an issue that has been present since 2.91.90).
Comment 10 rudolf 2015-10-16 15:43:44 EDT
(In reply to Florian Müllner from comment #9)
 
> Feel free to ask for it by setting the blocker? flag
I probably can't, I see only needinfo flag in Flags section

> number of users who were annoyed enough to take it to bugzilla is very small
I guess it wasn't too obvious before 3.8 and GNOME Classic, and even now many people use either basic GNOME Shell without window-list, or something like Frippery Bottom Panel that doesn't have this problem.

IMO it should be fixed given that GNOME Classic is default desktop on RHEL, and this bug breaks UX.
Comment 11 Florian Müllner 2016-03-04 10:42:24 EST
Addressed in gnome-shell-3.14.4-38.el7.
Comment 14 Michael Boisvert 2016-09-19 15:19:18 EDT
I was able to "two click" a minimized gedit window while leaving the workspace selection window open. Two clicks meaning, one to cancel the workspace selection window and the second click to maximize the gedit instance. Same goes for right clicking. 

Verified.
Comment 16 errata-xmlrpc 2016-11-03 21:41:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2258.html

Note You need to log in before you can comment on or make changes to this bug.