Bug 126869 - udp checksum error with e1000 driver connected via cisco vpn client
Summary: udp checksum error with e1000 driver connected via cisco vpn client
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 157147 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-28 16:20 UTC by Ian Amess
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Network trace for DNS request (3.47 KB, text/plain)
2004-06-28 16:22 UTC, Ian Amess
no flags Details
output from lspci -v (6.57 KB, text/plain)
2004-06-28 16:24 UTC, Ian Amess
no flags Details

Description Ian Amess 2004-06-28 16:20:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When using cisco vpn client 4.0.4 and kernel 2.6.6-1.435 with e1000
driver a DNS request will fail with a checksum error at the DNS
server. Other network based operations will work fine but not dns
(possibly other udp based connections will fail but have not tested
any other). This seems to be specific to the e1000 driver as
connections made using ipw2100 wireless driver will work ok, have also
tested on another machine running same kernel release but using the
e100 driver which also works, also this problem was not there in
2.6.5-1.358 kernel release. I have attached a file containing an
extract from a network monitoring application (not sure what it is I
didn't run the trace). I should stress that this only manifests itself
when connecting through the cisco vpnclient normal non-ipsec tunnel
operation works a expected. 

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.435

How reproducible:
Always

Steps to Reproduce:
1. Connect to vpn concentrator using cisco vpnclient 4.0.4

2. run dig @server www.theregister.co.uk
3.
    

Actual Results:  Dig will report timeout error.

Expected Results:  Resolve host.

Additional info:

My machine is a Tecra M1 run FC2 lspci output is attached.

Comment 1 Ian Amess 2004-06-28 16:22:38 UTC
Created attachment 101473 [details]
Network trace for DNS request

Comment 2 Ian Amess 2004-06-28 16:24:01 UTC
Created attachment 101474 [details]
output from lspci -v

Comment 3 Arjan van de Ven 2004-06-28 16:24:26 UTC
this is a long standing bug in the cisco vpn binary module where it
doesn't deal correctly with zero copy networking and corrupts
checksums. Please file this with cisco not us, there's nothing we can do.
(and fwiw, your wireless card isn't doing zero copy networking so
doesn't see the issue)

*** This bug has been marked as a duplicate of 78616 ***

*** This bug has been marked as a duplicate of 78616 ***

Comment 4 Ian Amess 2004-06-28 16:38:41 UTC
Ok thanks, but I have one question what changed between 2.6.5-1.358
and 2.6.6-1.435 to bring out this bug?

Comment 5 Ian Amess 2004-06-28 16:41:19 UTC
Ok thanks, but I have one question what changed between 2.6.5-1.358
and 2.6.6-1.435 to bring out this bug?

Comment 6 Christian Rank 2004-08-24 11:48:03 UTC
I had the same problem with generic kernel 2.6.7 and solved it by
switching off the checksumming for the NIC:
   ethtool -K eth0 tx off

Comment 7 Rod Nayfield 2005-05-07 16:13:40 UTC
*** Bug 157147 has been marked as a duplicate of this bug. ***

Comment 8 Red Hat Bugzilla 2006-02-21 19:04:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.