This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1268717 - AeroGear UnifiedPush Server cartridge always causes OutOfMemoryError when it started in small gear
AeroGear UnifiedPush Server cartridge always causes OutOfMemoryError when it ...
Status: CLOSED DUPLICATE of bug 1250910
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Lamb
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-04 21:11 EDT by Kenjiro Nakayama
Modified: 2015-10-16 16:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-16 16:44:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2015-10-04 21:11:23 EDT
Description of problem:

- When I start AeroGear UnifiedPush Server in , it always causes OutOfMemoryError.

Version-Release number of selected component (if applicable):

- OpenShift Online (Current version) *5/10/2015

How reproducible:

Steps to Reproduce:

1. Create or start aeroGear UnifiedPush Server cartridge applicatoin in small gear.
2. The server may start, but it will cause OutOfMemoryError after 30 seconds.

Additional info:

- When the aeroGear cartridge start in small gear, its Max Heap size set as 256m. But it would cause OutOfMemoryError.

- Attached the server.log 

TOBE:

- Raise the default max heap size, or don't allow to create it on small gears.
Comment 2 John W. Lamb 2015-10-16 16:44:22 EDT
The Aerogear cartridge doesn't work with small gears. The installation instructions specify that you have to run "rhc create-app" with "--gear-size medium": https://github.com/aerogear/openshift-origin-cartridge-aerogear-push#installation

Medium gears are available for Bronze and Silver tier customers.

A duplicate issue has already been forwarded to the Aerogear team; I'm not sure what priority this issue might have for them. They can either modify the quickstart to work with small gears, or (what seems much more likely) they need to clarify the gear size requirements in the instructions.

*** This bug has been marked as a duplicate of bug 1250910 ***

Note You need to log in before you can comment on or make changes to this bug.