Bug 1268761 - [RFE] Request to provide openshift/base-rhel7 image from registry.access.redhat.com
[RFE] Request to provide openshift/base-rhel7 image from registry.access.redh...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Ben Parees
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 03:51 EDT by Kenjiro Nakayama
Modified: 2016-10-27 02:00 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-19 08:39:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2015-10-05 03:51:56 EDT
1. Proposed title of this feature request

  - [RFE] Request to provide openshift/base-rhel7 image from registry.access.redhat.com.

2. Who is the customer behind the request?

  - I (Kenjiro Nakayama) fill here as private comment.

3. What is the nature and description of the request?

  - The customer wants Red Hat to provide base-rhel7 via registry.access.redhat.com.

4. Why does the customer need this? (List the business requirements here)

  - The customer needs to create base-rhel7 by themselves. If Red Hat doesn't provide the image, every time a new rhel7 image comes out, they need to create a new base-rhel7 image.

5. How would the customer like to achieve this? (List the functional requirements here)

  - They just want to use base-rhel7 which is provided via registry.access.redhat.com.

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.

  -  RedHat already uses this image, it is just not officially available. As RedHat already uses the image, it has also been tested already.

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?

  - No, there isn't.

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?

  - ASAP, as we would like to use it for STI builds

9. Is the sales team involved in this request and do they have any additional input?

  - No.

10. List any affected packages or components.

  - No, there are no affect to any other packages/components.

11. Would the customer be able to assist in testing this functionality if implemented?

  - Yes. We would use it for STI builds, and thus it would be tested as well.
Comment 2 Ben Parees 2015-10-05 03:56:04 EDT
Scott I assume you're already building base-rhel7 on OSBS so do you see any problem with publishing it to registry.access.redhat.com?  I can't think of any myself, as long as we add it to the list of things we already re-publish.
Comment 13 Dan McPherson 2016-04-14 18:07:48 EDT
@knakayam Can you clarify please?
Comment 14 Eric Rich 2016-05-17 14:42:26 EDT
I think this is already offered with: 

redhat.com   registry.access.redhat.com/rhscl/s2i-base-rhel7                      Base image delivers all the essential libr...   0                    

Can QE confirm that this images is tested with OpenShift, I don't see it listed on https://access.redhat.com/articles/2176281
Comment 15 Wenjing Zheng 2016-05-18 06:17:23 EDT
1. I tried to use the image to build ruby-22-rhel7 image and it failed with below error (I have registered local machine to subscribe-manager):
    Step 6 : RUN yum-config-manager --enable rhel-server-rhscl-7-rpms &&     yum-config-manager --enable rhel-7-server-optional-rpms &&     INSTALL_PKGS="rh-ruby22 rh-ruby22-ruby-devel rh-ruby22-rubygem-rake v8314 rh-ruby22-rubygem-bundler nodejs010" &&     yum install -y --setopt=tsflags=nodocs $INSTALL_PKGS && rpm -V $INSTALL_PKGS &&     yum clean all -y
     ---> Running in 0cb4c3ba4e09
    Loaded plugins: ovl, product-id
    Loaded plugins: ovl, product-id
    Loaded plugins: ovl, product-id, search-disabled-repos, subscription-manager
    No package rh-ruby22 available.
    No package rh-ruby22-ruby-devel available.
    No package rh-ruby22-rubygem-rake available.
    No package v8314 available.
    No package rh-ruby22-rubygem-bundler available.
    No package nodejs010 available.
    Error: Nothing to do
    The command '/bin/sh -c yum-config-manager --enable rhel-server-rhscl-7-rpms &&     yum-config-manager --enable rhel-7-server-optional-rpms &&     INSTALL_PKGS="rh-ruby22 rh-ruby22-ruby-devel rh-ruby22-rubygem-rake v8314 rh-ruby22-rubygem-bundler nodejs010" &&     yum install -y --setopt=tsflags=nodocs $INSTALL_PKGS && rpm -V $INSTALL_PKGS &&     yum clean all -y' returned a non-zero code: 1
    make: *** [build] Error 1

2. But if I clone https://github.com/openshift/s2i-base locally and build base image based on this repo then try to build ruby-22-rhel7 image, it succeeds.
Comment 17 Ben Parees 2016-05-18 08:22:02 EDT
Honza, what's the delta between our base-rhel7 image:
https://github.com/openshift/s2i-base/blob/master/Dockerfile.rhel7

and the SCL rhscl/s2i-base-rhel7 image?
Comment 20 Wenjing Zheng 2016-05-23 22:39:38 EDT
In this case, I am using the invalid "rhel7.2" image pulled from docker.io when building base image myself, so try again with registry.access.redhat.com/rhel7.2, also failed to build base-image with below errors:
failure: repodata/repomd.xml from rhel-sap-hana-for-rhel-7-server-eus-rpms: [Errno 256] No more mirrors to try.
https://cdn.redhat.com/content/eus/rhel/server/7/7Server/x86_64/sap-hana/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
The command '/bin/sh -c yum-config-manager --enable rhel-7-server-optional-rpms &&   INSTALL_PKGS="autoconf   automake   bsdtar   findutils   gcc-c++   gd-devel   gdb   gettext   git   libcurl-devel   libxml2-devel   libxslt-devel   lsof   make   mariadb-devel   mariadb-libs   openssl-devel   patch   postgresql-devel   procps-ng   scl-utils   sqlite-devel   tar   unzip   wget   which   yum-utils   zlib-devel" &&   mkdir -p ${HOME}/.pki/nssdb &&   chown -R 1001:0 ${HOME}/.pki &&   yum install -y --setopt=tsflags=nodocs $INSTALL_PKGS &&   rpm -V $INSTALL_PKGS &&   yum clean all -y &&   useradd -u 1001 -r -g 0 -d ${HOME} -s /sbin/nologin       -c "Default Application User" default &&   chown -R 1001:0 /opt/app-root' returned a non-zero code: 1
make: *** [build] Error 1
Comment 21 Ben Parees 2016-05-23 23:14:18 EDT
Wenjing:

so how did you successfully build the base-rhel7 (not the rhscl one) image?

The only way i'd expect you to be able to build it is using the rhel7.2 image that's part of the AMI.
Comment 22 Wenjing Zheng 2016-05-23 23:34:18 EDT
Unfortunately, I cannot even build base-rhel7 image with my old way now (tried both with docker.io/rhel7.2 and registry.access.redhat.com/rhel7.2)
Comment 23 Ben Parees 2016-05-23 23:48:42 EDT
that actually matches what i would expect.  the only rhel7.2 image that will work as the base is the one that's part of the AMIs we produce.
Comment 27 Dan McPherson 2016-09-19 08:39:30 EDT
Closing as

registry.access.redhat.com/rhscl/s2i-base-rhel7

is available and seems to suit the requested purpose.

Note You need to log in before you can comment on or make changes to this bug.