Bug 1268763 - global ctags and other plugins can't be used because config file lists wrong install paths
global ctags and other plugins can't be used because config file lists wrong ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: global (Show other bugs)
22
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 04:06 EDT by KevinFarshaw
Modified: 2015-11-21 11:50 EST (History)
3 users (show)

See Also:
Fixed In Version: global-6.5.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-21 11:50:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH: Assume shlibs live in lib64/ and s/.la/.so/g (27.70 KB, patch)
2015-10-05 04:06 EDT, KevinFarshaw
no flags Details | Diff

  None (edit)
Description KevinFarshaw 2015-10-05 04:06:40 EDT
Created attachment 1079855 [details]
PATCH: Assume shlibs live in lib64/ and s/.la/.so/g

Description of problem:

    When using global to index code using its ctags plugin, the tool
    exists with an error:

    gtags: cannot open shared object '/usr/lib/gtags/exuberant-ctags.la'.

    The same problem probably exists for the other plugin bundled with
    global, a pygmentize wrapper.

Version-Release number of selected component (if applicable):

     6.3.3-1

How reproducible:

     Always

Steps to Reproduce:

     1. In any directory: "GTAGSLABEL=ctags gtags ."

Actual results:

     exits with:

     gtags: cannot open shared object '/usr/lib/gtags/exuberant-ctags.la'.

Expected results:

     Should find shlib (which *is* installed in /usr/lib64/gtags/*.so)
     and run.

Additional info:

     The problem is in gtags.conf.in template which uses insert "$prefix/lib/"
     instead of "$libdir", and also names the .la files (which the SPEC erases)
     instead of the .so files.

     patch attached which fixes the problem, assuming x86_64.
     The correct fix would be to change gtags.conf.in, but that requires 
     changes to configure.ac and the autoreconf, and versions, and the 
     patch becomes huge. I really can't spend 3 days on this, and good chances 
     this will be ignored anyway as in previous bugs I've reported.
Comment 1 KevinFarshaw 2015-10-06 12:21:48 EDT
email send bug-global@gnu.org about $libdir not being used.

Also note upstream released 6.5.1, Sep 2015.
Comment 2 KevinFarshaw 2015-10-10 08:37:24 EDT
upstream bug report finally showed up in their ML archive:
https://lists.gnu.org/archive/html/bug-global/2015-10/msg00002.html
Comment 3 KevinFarshaw 2015-10-13 06:17:03 EDT
Upstream maintainer Shigio Yamaguchi has posted patches fixing
this issue, see linked thread above. Should be in next released version,
but trivially applies to current version as well.
Comment 4 KevinFarshaw 2015-10-18 17:48:12 EDT
Bump. The default install is broken, Upstream is patched. Please fix.
Comment 5 KevinFarshaw 2015-10-24 18:05:30 EDT
Bump. Upstream has fixed this.
Comment 6 Robin Lee 2015-11-12 01:14:25 EST
I am happy to co-maintain this package. Can you approve me on pkgdb? My FAS id is cheeselee.
Comment 7 Pavel Zhukov 2015-11-12 02:47:42 EST
(In reply to Robin Lee from comment #6)
> I am happy to co-maintain this package. Can you approve me on pkgdb? My FAS
> id is cheeselee.

Done.
THanks and enjoy!
Comment 8 Robin Lee 2015-11-12 03:00:14 EST
(In reply to Pavel Zhukov from comment #7)
> (In reply to Robin Lee from comment #6)
> > I am happy to co-maintain this package. Can you approve me on pkgdb? My FAS
> > id is cheeselee.
> 
> Done.
> THanks and enjoy!

Great!
Comment 9 Fedora Update System 2015-11-12 13:02:55 EST
global-6.5.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ccbe1a5b07
Comment 10 Fedora Update System 2015-11-12 23:23:42 EST
global-6.5.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update global'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ccbe1a5b07
Comment 11 Fedora Update System 2015-11-21 11:50:37 EST
global-6.5.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.