Bug 1268764 - AttributeError: 'str' object has no attribute 'busid'
AttributeError: 'str' object has no attribute 'busid'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
s390x Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
abrt_hash:efb59ed29767357c116eb596729...
:
Depends On:
Blocks: ZedoraTracker F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-05 04:09 EDT by Jan Stodola
Modified: 2015-10-19 17:09 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-23.19.7-1 anaconda-23.19.7-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 17:09:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dnf.log (3.00 KB, text/plain)
2015-10-05 04:10 EDT, Jan Stodola
no flags Details
File: environ (459 bytes, text/plain)
2015-10-05 04:10 EDT, Jan Stodola
no flags Details
File: lsblk_output (1.73 KB, text/plain)
2015-10-05 04:10 EDT, Jan Stodola
no flags Details
File: nmcli_dev_list (1.36 KB, text/plain)
2015-10-05 04:10 EDT, Jan Stodola
no flags Details
File: os_info (451 bytes, text/plain)
2015-10-05 04:10 EDT, Jan Stodola
no flags Details
File: storage.log (74.02 KB, text/plain)
2015-10-05 04:10 EDT, Jan Stodola
no flags Details
File: packaging.log (537 bytes, text/plain)
2015-10-05 04:10 EDT, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2015-10-05 04:09:57 EDT
Description of problem:
1. started vnc installation on s390x
2. proceeded to the Installation destination spoke
3. selected all DASD disks
4. tried to enter the custom partitioning spoke -> traceback

Version-Release number of selected component:
anaconda-23.19.4-1

The following was filed automatically by anaconda:
anaconda 23.19.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 655, in make_unformatted_dasd_list
    if blockdev.s390.dasd_needs_format(dasd.busid):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 786, in _check_dasd_formats
    dasds = self.storage.devicetree.make_unformatted_dasd_list(self.selected_disks)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 915, in on_back_clicked
    rc = self._check_dasd_formats()
AttributeError: 'str' object has no attribute 'busid'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   repo=http://s390pkgs.fedoraproject.org/compose/23_Beta_RC1/23/Server/s390x/os/ ro ramdisk_size=40000 cio_ignore=all,!condev rd.dasd=0.0.3527 rd.dasd=0.0.3727 rd.dasd=0.0.3627 rd.znet=qeth,0.0.0a00,0.0.0a01,0.0.0a02,layer2=1,portno=0,portname=FOOBAR ip=10.16.105.198::10.16.111.254:21:rtt7.s390.bos.redhat.com:enccw0.0.0a00:none nameserver=10.16.36.29 nameserver=10.11.5.19 inst.noverifyssl BOOT_IMAGE=0
dnf.rpm.log:    Oct 05 08:05:48 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.s390x
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 3 Jan Stodola 2015-10-05 04:10:02 EDT
Created attachment 1079858 [details]
File: dnf.log
Comment 4 Jan Stodola 2015-10-05 04:10:03 EDT
Created attachment 1079859 [details]
File: environ
Comment 5 Jan Stodola 2015-10-05 04:10:04 EDT
Created attachment 1079860 [details]
File: lsblk_output
Comment 6 Jan Stodola 2015-10-05 04:10:06 EDT
Created attachment 1079861 [details]
File: nmcli_dev_list
Comment 7 Jan Stodola 2015-10-05 04:10:07 EDT
Created attachment 1079862 [details]
File: os_info
Comment 9 Jan Stodola 2015-10-05 04:10:09 EDT
Created attachment 1079864 [details]
File: storage.log
Comment 12 Jan Stodola 2015-10-05 04:10:13 EDT
Created attachment 1079867 [details]
File: packaging.log
Comment 13 Jan Stodola 2015-10-05 04:18:31 EDT
Also happens when trying to reclaim disk space.
Comment 14 Fedora Blocker Bugs Application 2015-10-05 08:06:53 EDT
Proposed as a Blocker for 23-final by Fedora user jstodola using the blocker tracking app because:

 Violating the following criteria:
* https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#Installation_interfaces
* https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria#Custom_partitioning

Note that this only applies to the s390x architecture.
Comment 15 Samantha N. Bueno 2015-10-05 09:47:09 EDT
Pretty sure this won't be approved since it happens on a secondary arch, but final freeze isn't until next week, and I can fix this before then. Should be a low-impact change.
Comment 16 Adam Williamson 2015-10-05 15:46:49 EDT
Discussed at 2015-10-05 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-05/f23-blocker-review.2015-10-05-16.00.html . Rejected as a release blocker as it affects only a secondary arch; accepted as a freeze exception as it seems like a serious issue for that arch and we generally grant freeze exceptions for such cases. Of course, the fix should only be taken if it is safe.
Comment 17 Samantha N. Bueno 2015-10-06 11:38:59 EDT
(In reply to awilliam@redhat.com from comment #16)
> Of course, the fix should only be taken if it is safe.

Yes, it is quite safe -- it is a small fix isolated only to s390x pieces of code, nothing in blivet is touched (saw some mention of concern about that in the meeting logs).
Comment 18 Fedora Update System 2015-10-15 13:28:46 EDT
anaconda-23.19.7-1.fc23 python-blivet-1.12.7-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c70e34d416
Comment 19 Fedora Update System 2015-10-15 16:53:48 EDT
anaconda-23.19.7-1.fc23, python-blivet-1.12.7-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-blivet anaconda'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c70e34d416
Comment 20 Jan Stodola 2015-10-19 07:14:18 EDT
No longer able to reproduce with anaconda-23.19.7-1.fc23.

Thanks, moving to VERIFIED.
Comment 21 Fedora Update System 2015-10-19 17:09:01 EDT
anaconda-23.19.7-1.fc23, python-blivet-1.12.7-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.