This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1268786 - No sound after Fedora 23 upgrade (Dell XPS 2015)
No sound after Fedora 23 upgrade (Dell XPS 2015)
Status: CLOSED DUPLICATE of bug 1255070
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 04:53 EDT by Guillaume Kulakowski
Modified: 2015-11-25 08:08 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 14:25:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guillaume Kulakowski 2015-10-05 04:53:35 EDT
Description of problem:
After a Fedora 23 upgrade using dnf system upgrade, I have no sound on my Dell XPS 2015.
If I use a F22 live USB after some cold reboot I have sound.
I thinks that F23 has disabled my sound card at the hardware level. After multiple F23 reboot / F22 Live USB boot / prayer I have sound.... But I loose it after boot.

With Fedora 22: no problem with my sound card.


Version-Release number of selected component (if applicable):
kernel-4.2.2-300.fc23

How reproducible:
Difficile... Use a Dell XPS 2015, boot, reboot, etc.


Expected results:
Have souond on each boot.

Additional info:
No dual-boot with other OS.
Comment 1 Justin M. Forbes 2015-10-05 11:59:18 EDT
The proper solution here is to update your firmware to revision A05 or newer.
Comment 2 Guillaume Kulakowski 2015-10-05 12:02:19 EDT
I have already a firmware A05 :-). I'm not the only person, see https://bugzilla.redhat.com/show_bug.cgi?id=1188741 for me it's a regression.
Comment 3 Mads Villadsen 2015-10-05 12:22:03 EDT
I'm also on A05. Do we need to provide anything special to help with debugging?
Comment 4 Justin M. Forbes 2015-10-05 13:33:30 EDT
What does 'aplay -l' show?
Comment 5 Guillaume Kulakowski 2015-10-05 13:49:24 EDT
Hi,

~~~
aplay -l      
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: HDMI [HDA Intel HDMI], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0
carte 0: HDMI [HDA Intel HDMI], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: HDMI [HDA Intel HDMI], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: broadwellrt286 [broadwell-rt286], périphérique 0: System Playback/Capture (*) []
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: broadwellrt286 [broadwell-rt286], périphérique 1: Offload0 Playback (*) []
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: broadwellrt286 [broadwell-rt286], périphérique 2: Offload1 Playback (*) []
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
~~~
Comment 6 Guillaume Kulakowski 2015-10-05 15:12:00 EDT
A firmware seem missing:

~~~
root@stargazer ~llaumgui> dmesg G audio          
[    9.930978] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   10.027169] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for intel/IntcPP01.bin failed with error -2
[   10.027174] haswell-pcm-audio haswell-pcm-audio: fw image intel/IntcPP01.bin not available(-2)
[   10.037690] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[   10.075463] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System Pin mapping ok
[   10.075505] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload0 Pin mapping ok
[   10.075544] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload1 Pin mapping ok
[   10.075579] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Loopback Pin mapping ok
[   10.081492] broadwell-audio broadwell-audio: rt286-aif1 <-> snd-soc-dummy-dai mapping ok
[   10.094779] input: broadwell-rt286 Headset as /devices/pci0000:00/INT3438:00/broadwell-audio/sound/card0/input17
[   49.846418] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[  114.862085] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[  243.225287] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[  322.202170] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[  410.630028] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[  647.334020] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
~~~
Comment 7 Guillaume Kulakowski 2015-10-05 15:42:09 EDT
After searching (a lot) on Google, is there a bug in iés detection introduced in 4.2...
Comment 8 Guillaume Kulakowski 2015-10-06 02:14:09 EDT
I have made some test:
- 2 cold boot on F22 Live USB enable sound on Fedora 22 and first F23 boot.
- reboot loose sound
- Kernel parameter acpi_rev_override doesn't work.

Can I reopen the bug ?
Comment 9 Guillaume Kulakowski 2015-10-06 05:45:30 EDT
The solution seem to be this patch https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=18d78b64fddc11eb336f01e46ad3303a3f55d039 and using "acpi_rev_override".
Comment 10 Justin M. Forbes 2015-10-06 09:58:38 EDT
That patch is in mainline, but the feature is not enabled because it changes the way that acpi reports, and this can have other impacts.  It was a bandaid solution until i2c support was working, but it is not appropriate for the Fedora kernel.
Comment 11 Justin M. Forbes 2015-10-06 10:13:27 EDT
It looks like alsa is using your Intel HDMI output as the first card connected.  Have you tried opening the settings and making sure the broadwellrt286 device is selected?
Comment 12 Guillaume Kulakowski 2015-10-06 10:47:55 EDT
> Have you tried opening the settings and making sure the broadwellrt286 device is selected?
Not on the first cold boot, yes after.

I will try this Copr kernel: https://copr.fedoraproject.org/coprs/godsic/kernel-acpi-rev-override/
Comment 13 Guillaume Kulakowski 2015-10-06 14:25:14 EDT
Workaround on #1268786 work for me... It's a tempory solution waiting 4.3.

*** This bug has been marked as a duplicate of bug 1255070 ***

Note You need to log in before you can comment on or make changes to this bug.