Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1268797 - activation stage already scheduled error in logs
Summary: activation stage already scheduled error in logs
Keywords:
Status: CLOSED DUPLICATE of bug 1183444
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 7.2
Assignee: Thomas Haller
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-05 09:38 UTC by Vladimir Benes
Modified: 2015-10-07 15:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-07 15:02:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vladimir Benes 2015-10-05 09:38:20 UTC
Description of problem:
I have active connection and this is in logs:

Oct 05 05:30:09 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037409.403903] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:30:16 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037416.403561] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:30:26 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037426.494604] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:30:34 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037434.403531] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:30:41 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037441.547829] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:31:02 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037462.404314] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:31:11 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037471.403587] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:31:23 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037483.619684] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:31:23 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037483.619844] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:31:46 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037506.403993] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:32:04 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037524.623960] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled
Oct 05 05:32:21 qe-dell-ovs5-vm-22.dqe.lab.eng.bos.redhat.com NetworkManager[6554]: <error> [1444037541.404231] [devices/nm-device.c:2620] activation_source_schedule(): (eth0): activation stage already scheduled


Version-Release number of selected component (if applicable):
NetworkManager-1.0.6-13.el7.x86_64

Comment 1 Thomas Haller 2015-10-06 08:47:19 UTC
I think this is a regression from bug 1183444.

it should be fixed by moving
  activation_source_clear (self, FALSE, 0);
before
  if (!priv->master_ready_handled) {

http://cgit.freedesktop.org/NetworkManager/NetworkManager/tree/src/devices/nm-device.c?id=9796eace518c18fbde1fda1f8c4cced91e710f8c#n2795




Verifying...

Comment 4 Thomas Haller 2015-10-07 15:02:45 UTC
So,

the major cause (regression of bug 1183444) is fixed again.

And the other known occurrence was bug 1245463. That one got cloned to bug 1269520 (and is fixed too).

*** This bug has been marked as a duplicate of bug 1183444 ***


Note You need to log in before you can comment on or make changes to this bug.