Bug 1268802 - updates-testing is still enabled for Fedora 23
updates-testing is still enabled for Fedora 23
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-repos (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-10-05 06:08 EDT by Kamil Páral
Modified: 2015-10-24 00:33 EDT (History)
6 users (show)

See Also:
Fixed In Version: fedora-repos-23-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-24 00:33:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2015-10-05 06:08:51 EDT
Description of problem:
Updates-testing repo needs to be disabled in Fedora 23 Final. It's still enabled. This blocks RC1 compose.

Version-Release number of selected component (if applicable):
fedora-repos-23-0.4.noarch
Comment 1 Kamil Páral 2015-10-05 06:09:23 EDT
This is a Final blocker, perhaps even an automatic one.
Comment 2 Adam Williamson 2015-10-05 18:39:39 EDT
Discussed at 2015-10-05 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-05/f23-blocker-review.2015-10-05-16.00.html . While we don't usually bother filing a blocker bug for this as it's usually taken care of as a matter of course by the relevant folks, this does technically meet the criteria, so since it's been filed, we accepted it as a blocker.

We're not asking for anything different from usual here - just that as usual a fedora-release that disables the updates-testing repo needs to be shipped at the appropriate point on the calendar (shortly before RC1 is composed, I guess).
Comment 3 Fedora Update System 2015-10-20 00:08:11 EDT
fedora-repos-23-1 fedora-release-23-1 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6656b35afd
Comment 4 Fedora Update System 2015-10-20 17:57:58 EDT
fedora-release-23-1, fedora-repos-23-1 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update fedora-release fedora-repos'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6656b35afd
Comment 5 Jens Petersen 2015-10-22 23:57:57 EDT
I think this needs to be tagged to f23 for the GA Live images?
Comment 6 Jens Petersen 2015-10-23 00:02:36 EDT
Okay nevermind sorry fedora-repos-23-1 is in RC2 and RC3.
Comment 7 Adam Williamson 2015-10-23 01:40:48 EDT
Jens: if you want to follow the process, follow the TC/RC compose requests. 23 Final compose request ticket is:

https://fedorahosted.org/rel-eng/ticket/6266

as you can see, when we (QA) request a new TC/RC build, we list various packages that should be pulled into the compose to fix blocker/FE bugs, which have not yet made it to stable. These packages are pulled into a repo called 'bleed':

http://kojipkgs.fedoraproject.org/mash/bleed/

which is then included in the compose. In Spherical Cow Land this would never be necessary; the 'intended' process is that the updates are sent out, we test and karma them, push them to stable (manually, when freeze is in effect), and *then* compose, and the composes just contain whatever's in stable. But in practice, given Fedora's short schedules, we don't have time to wait for that process in all cases. And then there are things like lorax and anaconda updates where we need a compose before we can actually *test* the update and give it karma and push it stable (the catch-22 problem).

Hence, we have this little process.

Through the MAGIC OF COPY/PASTE, if you CC yourself on the current compose request ticket, you'll be CCed on all new ones for eternity (or until you un-CC yourself again, or me/whoever else creates the compose request ticket for a new milestone buggers up the copy/paste).
Comment 8 Wolnei Junior 2015-10-23 12:53:06 EDT
Updates-testing is disabled on RC3.
Comment 9 Fedora Update System 2015-10-24 00:33:40 EDT
fedora-release-23-1, fedora-repos-23-1 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.