Bug 1268805 - perl-MouseX-App-Cmd-0.30-4.fc24 FTBFS: Failed test 'Internal hashes match' at t/build_emulates_new.t line 18
perl-MouseX-App-Cmd-0.30-4.fc24 FTBFS: Failed test 'Internal hashes match' at...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-MouseX-App-Cmd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On: 1286673
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 06:18 EDT by Petr Pisar
Modified: 2016-02-16 11:12 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-MouseX-App-Cmd-0.30-5.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 11:12:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed upstream fix ported to 0.30. (1.58 KB, patch)
2015-11-30 08:45 EST, Petr Pisar
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 107068 None None None Never

  None (edit)
Description Petr Pisar 2015-10-05 06:18:53 EDT
perl-MouseX-App-Cmd-0.30-4.fc24 fails to build in F24 because a test fails:

t/basic.t ............... ok
#   Failed test 'Internal hashes match'
#   at t/build_emulates_new.t line 18.
#     Structures begin differing at:
#          $got->{show_version} = Does not exist
#     $expected->{show_version} = '0'
# Looks like you failed 1 test of 1.
t/build_emulates_new.t .. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests
Comment 1 Petr Pisar 2015-11-30 08:44:42 EST
I posted a fix to upstream. The fix requires a new dependency.
Comment 2 Petr Pisar 2015-11-30 08:45 EST
Created attachment 1100506 [details]
Proposed upstream fix ported to 0.30.
Comment 3 Fedora Update System 2015-12-01 10:20:25 EST
perl-App-Cmd-0.330-1.fc23 perl-Dist-Zilla-5.042-1.fc23 perl-MouseX-App-Cmd-0.30-5.fc23 perl-MouseX-Foreign-1.000-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-002c1b2c78
Comment 4 Fedora Update System 2015-12-01 10:20:27 EST
perl-App-Cmd-0.330-1.fc23 perl-Dist-Zilla-5.042-1.fc23 perl-MouseX-App-Cmd-0.30-5.fc23 perl-MouseX-Foreign-1.000-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-002c1b2c78
Comment 5 Fedora Update System 2015-12-01 17:31:08 EST
perl-App-Cmd-0.330-1.fc23, perl-Dist-Zilla-5.042-1.fc23, perl-MouseX-App-Cmd-0.30-5.fc23, perl-MouseX-Foreign-1.000-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update perl-MouseX-App-Cmd perl-MouseX-Foreign perl-Dist-Zilla perl-App-Cmd'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-002c1b2c78
Comment 6 Fedora Update System 2015-12-10 20:51:06 EST
perl-App-Cmd-0.330-1.fc23, perl-Dist-Zilla-5.042-1.fc23, perl-MouseX-App-Cmd-0.30-5.fc23, perl-MouseX-Foreign-1.000-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.