This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1268809 - Qt creator help is broken/missing.
Qt creator help is broken/missing.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt-creator (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sandro Mani
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 06:49 EDT by bugreports2005
Modified: 2017-07-24 15:21 EDT (History)
8 users (show)

See Also:
Fixed In Version: qt-creator-4.2.2-5.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 15:21:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bugreports2005 2015-10-05 06:49:45 EDT
Description of problem:

Qt Creator help is broken/missing.


Version-Release number of selected component (if applicable):

qt-creator-3.0.1-4.el7.x86_64


How reproducible:

Always


Steps to Reproduce:
1. yum install qt-creator
2. qtcreator
3. Choose Help/Contents from the menu

Actual results:

Error 404...
The page could not be found!
Error loading: qthelp://org.qt-project.qtcreator.301/doc/index.html


Expected results:

A helpful Qt Creator Manual opens.


Additional info:

What is missing seems to be /usr/share/doc/qtcreator/qtcreator.qch. With that in place, the help starts to work.
Comment 1 Robin Lee 2017-07-14 05:48:18 EDT
/usr/share/doc/qt-creator/qtcreator*.qch should be moved to /usr/share/doc/qt5, so that qt-creator can auto-detect them.
Comment 2 Sandro Mani 2017-07-14 05:54:50 EDT
Testing on Rawhide, if I do Help -> Contents, I get the Qt Creator Manual displayed as I would expect, and is correctly listed in the Contents tree. What is broken in your view?
Comment 3 Robin Lee 2017-07-14 06:04:23 EDT
I am on Fedora 26 with qt-creator-4.2.2-3.fc26.x86_64.
Can you check the actual path of qt-creator qch in Rawhide qt-creator?
Comment 4 Sandro Mani 2017-07-14 06:05:30 EDT
$ dnf repoquery -l qt-creator-doc.noarch
/usr/share/doc/qtcreator
/usr/share/doc/qtcreator/qtcreator-dev.qch
/usr/share/doc/qtcreator/qtcreator.qch
Comment 5 Sandro Mani 2017-07-14 06:08:58 EDT
Oh boy, someone "fixed" the docs on F26...

http://pkgs.fedoraproject.org/cgit/rpms/qt-creator.git/commit/?h=f26&id=251e4e56c3df51683b80f4accd999c45b1a615f8
Comment 6 Sandro Mani 2017-07-14 06:21:01 EDT
Fix building:
https://koji.fedoraproject.org/koji/buildinfo?buildID=918576
Comment 7 Ngo Than 2017-07-14 10:26:35 EDT
fixed and built for f26:
https://koji.fedoraproject.org/koji/taskinfo?taskID=20521899
Comment 8 Fedora Update System 2017-07-15 05:14:01 EDT
qt-creator-4.2.2-5.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0e2aafb9c7
Comment 9 Fedora Update System 2017-07-16 17:22:15 EDT
qt-creator-4.2.2-5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-0e2aafb9c7
Comment 10 Fedora Update System 2017-07-24 15:21:22 EDT
qt-creator-4.2.2-5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.