Bug 1268845 - GRUB_CMDLINE_LINUX_DEFAULT should be removed from /etc/default/grub during uninstall
Summary: GRUB_CMDLINE_LINUX_DEFAULT should be removed from /etc/default/grub during un...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Tereza Cerna
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-05 12:26 UTC by Tereza Cerna
Modified: 2016-11-04 07:25 UTC (History)
2 users (show)

Fixed In Version: tuned-2.7.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:25:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2479 normal SHIPPED_LIVE tuned bug fix and enhancement update 2016-11-03 14:08:42 UTC

Description Tereza Cerna 2015-10-05 12:26:05 UTC
File /etc/default/grub contain row with variable GRUB_CMDLINE_LINUX_DEFAULT if tuned is installed. If package tuned is uninstall, this row should not be in /etc/default/grub.

There is nonactual regex in %postun.

# rpm -q tuned
tuned-2.5.1-4.el7.noarch

# cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT=
GRUB_CMDLINE_LINUX_DEFAULT="${GRUB_CMDLINE_LINUX_DEFAULT:+$GRUB_CMDLINE_LINUX_DEFAULT }\$tuned_params"

# yum remove tuned 
# rpm -q tuned
balíček tuned není nainstalován

# cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT=
GRUB_CMDLINE_LINUX_DEFAULT="${GRUB_CMDLINE_LINUX_DEFAULT:+$GRUB_CMDLINE_LINUX_DEFAULT }\$tuned_params"

Row GRUB_CMDLINE_LINUX_DEFAULT=... should be removed during uninstall.

Comment 2 Jaroslav Škarvada 2015-10-06 12:24:01 UTC
The tuned footprint in /etc/default/grub was improved to deal with whitespaces, but the clean-up regex in SPEC wasn't updated.

Comment 5 Tereza Cerna 2016-08-08 13:36:06 UTC
=============================================
Verified in:
   tuned-2.7.0-1.el7.noarch
   tuned-profiles-realtime-2.7.0-1.el7.noarch
PASS
=============================================

# tuned-adm profile realtime
# cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT
GRUB_CMDLINE_LINUX_DEFAULT="${GRUB_CMDLINE_LINUX_DEFAULT:+$GRUB_CMDLINE_LINUX_DEFAULT }\$tuned_params"
# echo $?
0
# yum -y remove tuned
# cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT
# echo $?
1

=============================================
Reproduced in:
   tuned-2.5.1-4.el7.noarch
   tuned-profiles-realtime-2.5.1-4.el7.noarch
FAIL
=============================================

# tuned-adm profile realtime
# cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT
GRUB_CMDLINE_LINUX_DEFAULT="${GRUB_CMDLINE_LINUX_DEFAULT:+$GRUB_CMDLINE_LINUX_DEFAULT }\$tuned_params"
# echo $?
0
# yum -y remove tuned
# cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT
GRUB_CMDLINE_LINUX_DEFAULT="${GRUB_CMDLINE_LINUX_DEFAULT:+$GRUB_CMDLINE_LINUX_DEFAULT }\$tuned_params"
# echo $?
0

Comment 7 errata-xmlrpc 2016-11-04 07:25:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2479.html


Note You need to log in before you can comment on or make changes to this bug.