Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1268846 - xorg-x11-glamor should be obsoleted
Summary: xorg-x11-glamor should be obsoleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-05 12:29 UTC by Tomas Pelka
Modified: 2018-04-02 17:56 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-server-1.17.2-10.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 04:28:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2198 0 normal SHIPPED_LIVE Xorg server and driver bug fix and enhancement update 2015-11-19 08:04:34 UTC

Description Tomas Pelka 2015-10-05 12:29:57 UTC
Description of problem:
xorg-x11-glamor was dropped in 7.2 so I think xorg-x11-drv-ati should obsolete xorg-x11-glamor

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-7.5.0-3.el7

How reproducible:
100%

Steps to Reproduce:
1. update 7.1 to 7.2
2.
3.

Actual results:
Output from RPM Command:
error: Failed dependencies:
        libglamor.so.0()(64bit) is needed by (installed) xorg-x11-glamor-devel
-0.6.0-2.20140918git347ef4f.el7.x86_64
        xorg-x11-glamor(x86-64) = 0.6.0-2.20140918git347ef4f.el7 is needed by 
(installed) xorg-x11-glamor-devel-0.6.0-2.20140918git347ef4f.el7.x86_64

Expected results:


Additional info:

Comment 1 Adam Jackson 2015-10-05 18:46:20 UTC
This should properly be done in xserver, since that's what provides glamor now.  We're already doing this for the xorg-x11-glamor package but not xorg-x11-glamor-devel, oops.

Comment 5 errata-xmlrpc 2015-11-19 04:28:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2198.html


Note You need to log in before you can comment on or make changes to this bug.