Bug 1268864 - Cannot execute VDB which include UDF
Cannot execute VDB which include UDF
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.2.0
Unspecified Windows
unspecified Severity urgent
: ---
: ---
Assigned To: Barry LaFond
Matus Makovy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 09:26 EDT by Matej Kralik
Modified: 2015-11-17 13:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 13:05:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Project with VDB (66.19 KB, application/zip)
2015-10-05 09:26 EDT, Matej Kralik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2678 Blocker Closed Cannot execute VDB which include UDF 2017-10-25 10:29 EDT

  None (edit)
Description Matej Kralik 2015-10-05 09:26:20 EDT
Created attachment 1079968 [details]
Project with VDB

When I want execute VDB which include view Table with user define function, show me this dialog in the teiid designer : "Cannot execute VDB - still loading" and server show this stack trace:

ERROR [stderr] (teiid-async-threads - 1) Exception in thread "teiid-async-threads - 1" org.teiid.metadata.MetadataException: TEIID30387 Could not load UDF "ConcatNull", since its invocation class "userdefinedfunctions.ConcatNull" could not be found.
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.query.function.FunctionTree.createFunctionDescriptor(FunctionTree.java:285)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.query.function.FunctionTree.addFunction(FunctionTree.java:190)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.query.function.FunctionTree.<init>(FunctionTree.java:91)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.deployers.CompositeVDB.buildTransformationMetaData(CompositeVDB.java:85)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.deployers.CompositeVDB.metadataLoadFinished(CompositeVDB.java:265)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.deployers.VDBRepository.finishDeployment(VDBRepository.java:291)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.runtime.AbstractVDBDeployer.metadataLoaded(AbstractVDBDeployer.java:202)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.jboss.VDBService.access$1100(VDBService.java:85)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.jboss.VDBService$6.run(VDBService.java:411)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.jboss.VDBService$7.run(VDBService.java:442)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at java.lang.Thread.run(Thread.java:745)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.jboss.threads.JBossThread.run(JBossThread.java:122)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) Caused by: java.lang.ClassNotFoundException: userdefinedfunctions.ConcatNull from [Module "deployment.UdfVdb.vdb:main" from Service Module Loader]
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:213)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:459)
14:44:52,252 ERROR [stderr] (teiid-async-threads - 1) 	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:408)
14:44:52,253 ERROR [stderr] (teiid-async-threads - 1) 	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:389)
14:44:52,253 ERROR [stderr] (teiid-async-threads - 1) 	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:134)
14:44:52,253 ERROR [stderr] (teiid-async-threads - 1) 	at java.lang.Class.forName0(Native Method)
14:44:52,253 ERROR [stderr] (teiid-async-threads - 1) 	at java.lang.Class.forName(Class.java:348)
14:44:52,253 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.query.function.UDFSource.getInvocationClass(UDFSource.java:43)
14:44:52,253 ERROR [stderr] (teiid-async-threads - 1) 	at org.teiid.query.function.FunctionTree.createFunctionDescriptor(FunctionTree.java:275)
14:44:52,253 ERROR [stderr] (teiid-async-threads - 1) 	... 13 more

Steps to Reproduce:
1.import project from attachment
2.click right to UdfVdb (Modeling -> execute VDB)
Comment 1 JBoss JIRA Server 2015-10-09 04:13:50 EDT
Paul Richardson <p.g.richardson@phantomjinx.co.uk> updated the status of jira TEIIDDES-2678 to Resolved
Comment 2 JBoss JIRA Server 2015-10-21 02:37:27 EDT
Matus Makovy <mmakovy@redhat.com> updated the status of jira TEIIDDES-2678 to Closed

Note You need to log in before you can comment on or make changes to this bug.