Bug 1268882 - Broken symlink pointing to inherits@2
Broken symlink pointing to inherits@2
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: nodejs010 (Show other bugs)
nodejs010
Unspecified Unspecified
medium Severity medium
: rc
: 2.1
Assigned To: Tomas Hrcka
Miroslav Hradílek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 10:15 EDT by Miroslav Hradílek
Modified: 2016-02-22 09:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the symbolic link pointing to the inherits@2 directory was broken. Consequently, certain packages dependent on inherits had incorrect dependencies. With this update, all symlinks point directly to the inherits directory, and inherits@2 has been removed from the file system. This is possible because inherits in version 1.* were never shipped, so it is not necessary to use symlinks to point to inherits@2. As a result, all packages have correct dependencies.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 09:22:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Hradílek 2015-10-05 10:15:49 EDT
Description of problem:
Several modules have dependencies on inherits 2 module. Inherits is installed globally in 
/opt/rh/nodejs010/root/usr/lib/node_modules/inherits

but symlinks in affected packages are pointing to non existing target
/opt/rh/nodejs010/root/usr/lib/node_modules/inherits@2

Affected components:
nodejs010-nodejs-fstream-ignore-1.0.2-1.el6.noarch
  lrwxrwxrwx. 1 root root 54 Oct  5 09:34 /opt/rh/nodejs010/root/usr/lib/node_modules/fstream-ignore/node_modules/inherits -> /opt/rh/nodejs010/root/usr/lib/node_modules/inherits@2
nodejs010-nodejs-glob-4.0.5-1.el6.noarch
  lrwxrwxrwx. 1 root root 54 Oct  5 09:34 /opt/rh/nodejs010/root/usr/lib/node_modules/glob/node_modules/inherits -> /opt/rh/nodejs010/root/usr/lib/node_modules/inherits@2
nodejs010-nodejs-fstream-1.0.3-1.el6.noarch
  lrwxrwxrwx. 1 root root 54 Oct  5 09:34 /opt/rh/nodejs010/root/usr/lib/node_modules/fstream/node_modules/inherits -> /opt/rh/nodejs010/root/usr/lib/node_modules/inherits@2
nodejs010-nodejs-readable-stream-2.0.2-3.el6.noarch
  lrwxrwxrwx. 1 root root 54 Oct  5 09:36 /opt/rh/nodejs010/root/usr/lib/node_modules/readable-stream/node_modules/inherits -> /opt/rh/nodejs010/root/usr/lib/node_modules/inherits@2
nodejs010-nodejs-fstream-npm-1.0.1-1.el6.noarch
  lrwxrwxrwx. 1 root root 54 Oct  5 09:34 /opt/rh/nodejs010/root/usr/lib/node_modules/fstream-npm/node_modules/inherits -> /opt/rh/nodejs010/root/usr/lib/node_modules/inherits@2
nodejs010-nodejs-npmconf-1.1.8-2.el6.noarch
  lrwxrwxrwx. 1 root root 54 Oct  5 09:34 /opt/rh/nodejs010/root/usr/lib/node_modules/npmconf/node_modules/inherits -> /opt/rh/nodejs010/root/usr/lib/node_modules/inherits@2
nodejs010-nodejs-tar-1.0.3-1.el6.noarch
  lrwxrwxrwx. 1 root root 54 Oct  5 09:34 /opt/rh/nodejs010/root/usr/lib/node_modules/tar/node_modules/inherits -> /opt/rh/nodejs010/root/usr/lib/node_modules/inherits@2

How reproducible:
100%

Additional info:
This has been broken for a long time and I'm not exactly sure how come it even works. Our tests are obviously passing even with this bug. Either we are not hitting parts of the code needing inherits or the dependency somehow gets satisfied globally.
Comment 9 errata-xmlrpc 2016-02-22 09:22:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0285.html

Note You need to log in before you can comment on or make changes to this bug.