Bug 1268901 - wrong selinux context on /etc/rsyslog.conf after running spindown-disk
Summary: wrong selinux context on /etc/rsyslog.conf after running spindown-disk
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Tereza Cerna
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1305270
TreeView+ depends on / blocked
 
Reported: 2015-10-05 15:07 UTC by Tereza Cerna
Modified: 2016-11-04 07:25 UTC (History)
3 users (show)

(edit)
Clone Of:
: 1305270 (view as bug list)
(edit)
Last Closed: 2016-11-04 07:25:59 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2479 normal SHIPPED_LIVE tuned bug fix and enhancement update 2016-11-03 14:08:42 UTC

Description Tereza Cerna 2015-10-05 15:07:14 UTC
Wrong selinux context on /etc/rsyslog.conf after running spindown-disk. Currently there is tuned_var_run_t and should be syslog_conf_t.

# rpm -q tuned
tuned-2.5.1-4.el7.noarch

Comment 2 Jaroslav Škarvada 2015-10-06 09:42:19 UTC
It's because it uses 'cp' and doesn't fix the context.

Comment 4 paul 2016-02-06 03:15:54 UTC
Similar in 6.x ?  No fix for 6.x?

(Bug 1201966)
https://bugzilla.redhat.com/show_bug.cgi?id=1201966

Comment 5 Jaroslav Škarvada 2016-02-06 14:38:47 UTC
(In reply to paul from comment #4)
> Similar in 6.x ?  No fix for 6.x?
> 
> (Bug 1201966)
> https://bugzilla.redhat.com/show_bug.cgi?id=1201966

Right, thanks for pointing it out, I am cloning the bug to RHEL-6 to keep the context. Regarding the bug 1201966, if the issue is fixed for you by the commit from the comment 3, feel free to close it as a dupe.

Comment 6 paul 2016-02-07 00:03:04 UTC
Thanks!  I have a system probably 6.1 which later I found suffering same context problem, but originally in Bug 1201966 reported another seems related problem:

"The /etc/rsyslog.conf is restored to a default template upon system reboot.  Any changes to that file is lost after that reboot...."

Hope this help.

Comment 10 errata-xmlrpc 2016-11-04 07:25:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2479.html


Note You need to log in before you can comment on or make changes to this bug.