This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1268914 - oadm router liveness wrong when a different port is specified
oadm router liveness wrong when a different port is specified
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ram Ranganathan
zhaozhanqi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 11:24 EDT by Miheer Salunke
Modified: 2015-10-21 02:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 02:59:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miheer Salunke 2015-10-05 11:24:08 EDT
Description of problem:

If you specify different ports for node and port (like --ports '80:8080') when you create a router with hostnetwork=false, the liveness probe is configured to query 8080, but it checks the pod IP, so it fails because it should check the port 80.
Modifying the dc to set the liveness probe to query port 80 works, but I think it should be done by default.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Always

Steps to Reproduce:
1. As per description
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Josep 'Pep' Turro Mauri 2015-10-21 02:59:08 EDT
This turned out to be a confusion between host ports and container ports, not a bug.

Note You need to log in before you can comment on or make changes to this bug.