Bug 1268927 - check_log has incorrect hard coded paths
check_log has incorrect hard coded paths
Status: CLOSED DUPLICATE of bug 1256848
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Scott Wilkerson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 12:30 EDT by Del Stoliker
Modified: 2015-10-06 10:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 10:06:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Del Stoliker 2015-10-05 12:30:36 EDT
Description of problem:

The check_log plugin has incorrect hard coded paths for egrep and tail


Version-Release number of selected component (if applicable): 2.0.3-3


How reproducible:


Steps to Reproduce:
1. Execute the command to initialize the log check (for example): /usr/lib64/nagios/plugins/check_log -F /var/log/maillog -O /tmp/maillog -q bounced
2. Execute the command again to check the status.

Actual results:
/usr/lib64/nagios/plugins/check_log: line 199: /usr/bin/egrep: No such file or directory
/usr/lib64/nagios/plugins/check_log: line 202: /usr/bin/egrep: No such file or directory
/usr/lib64/nagios/plugins/check_log: line 205: /bin/tail: No such file or directory
/usr/lib64/nagios/plugins/check_log: line 205: /usr/bin/egrep: No such file or directory
()

Expected results:
Log check ok - 0 pattern matches found

Additional info:

Incorrect paths
...
GREP="/usr/bin/egrep"
DIFF="/usr/bin/diff"
TAIL="/bin/tail"
...

Should be
...
GREP="/bin/egrep"
DIFF="/usr/bin/diff"
TAIL="/usr/bin/tail"
...
Comment 1 Scott Wilkerson 2015-10-06 10:06:16 EDT

*** This bug has been marked as a duplicate of bug 1256848 ***

Note You need to log in before you can comment on or make changes to this bug.