Bug 1268971 - Drop dependency on redhat-lsb-core
Drop dependency on redhat-lsb-core
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Build (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3.2
Assigned To: Boris Ranto
ceph-qe-bugs
:
Depends On: 1298536
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 14:40 EDT by Colin Walters
Modified: 2016-02-29 09:43 EST (History)
12 users (show)

See Also:
Fixed In Version: ceph-0.94.5-2.el7cp
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:43:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 13374 None None None Never

  None (edit)
Description Colin Walters 2015-10-05 14:40:04 EDT
We are looking at adding the Ceph utilities to Atomic Host, and the ceph-common -> redhat-lsb-core -> postfix dependency (among others) is a bit problematic.

AFAICS we're only pulling in redhat-lsb-core for the legacy rados init script.  A native systemd version of this should be pretty easy.
Comment 2 Ken Dreyer (Red Hat) 2015-10-05 15:07:59 EDT
Proper systemd unit files are coming in RHCS 2.0.
Comment 4 Boris Ranto 2015-10-06 04:33:52 EDT
Upstream tracker issue to resolve this at least for infernalis/rhcs 2.0:

http://tracker.ceph.com/issues/13374
Comment 12 Ken Dreyer (Red Hat) 2015-10-14 14:05:32 EDT
Boris, could you please convert rbdmap to a systemd unit file?
Comment 14 Ken Dreyer (Red Hat) 2015-10-15 11:09:53 EDT
According to https://bugzilla.redhat.com/show_bug.cgi?id=1244158, this init script never worked on RHEL 7 anyway
Comment 24 Ken Dreyer (Red Hat) 2015-10-21 12:35:17 EDT
Re-targeting to RHCS 1.3.2
Comment 25 Boris Ranto 2015-10-26 10:08:06 EDT
FYI: The upstream PR that should help, here

https://github.com/ceph/ceph/pull/6363
Comment 26 Ken Dreyer (Red Hat) 2015-11-09 13:14:17 EST
PR was merged upstream, so we can take this in RHCS 1.3.2
Comment 27 Tanay Ganguly 2015-12-17 02:20:29 EST
Ken,

Can you please provide the steps to verify this defect.
Comment 28 Ken Dreyer (Red Hat) 2015-12-17 11:22:54 EST
Steps to reproduce:

1. yum install ceph-common
2. yum remove redhat-lsb-core

Actual (broken) results:
The ceph-common package will depend on redhat-lsb-core, so yum will try to remove ceph-common as well as redhat-lsb-core.

Expected (fixed) results:
The ceph-common package will not depend on redhat-lsb-core. Yum will be able to remove redhat-lsb-core without removing ceph-common.
Comment 31 Tanay Ganguly 2016-01-22 01:41:13 EST
Marking this BUG as verified.

Followed the steps mentioned in Step#5.
Also had IO running.
Comment 33 errata-xmlrpc 2016-02-29 09:43:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0313

Note You need to log in before you can comment on or make changes to this bug.