Bug 126904 - anaconda traceback while loading map480.png
Summary: anaconda traceback while loading map480.png
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-28 22:10 UTC by Will Woods
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 16:25:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Will Woods 2004-06-28 22:10:47 UTC
This has been observed in the rawhide-20040628-x86_64 tree. It might
happen with x86 etc. but those rawhide trees have other problems which
prevent testing.

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1064, in handleRenderCallback
    self.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 775, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 1111, in setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/usr/lib/anaconda/iw/timezone_gui.py", line 52, in getScreen
    self.tz = TimezoneMap(zonetab=zonetab, map=path)
  File "/usr/lib/anaconda/iw/timezone_map_gui.py", line 49, in __init__
    tpixbuf = gtk.gdk.pixbuf_new_from_file(map)
GError: Couldn't recognize the image file format for file
'/usr/share/anaconda/pixmaps/map480.png'

Comment 2 Jeremy Katz 2004-06-28 22:25:47 UTC
Due to gtk2 changes on Friday, change committed and built earlier
today that _should_ fix it.

Comment 3 Barry K. Nathan 2004-07-01 09:55:23 UTC
FWIW, I'm hitting this on anaconda-10.0.1-0.20040629211549 on an i686
machine.

Comment 5 Jeremy Katz 2004-07-03 05:57:04 UTC
How about 0702 stuff?  (I made more changes again late last night... 
the gtk changes didn't work with the same batch of stuff as I used for
pango :/)

Comment 6 Mike McLean 2004-07-07 15:50:55 UTC
Still happens with RHEL4-re0706.0 on x86_64, but not i386.



Comment 7 Jeremy Katz 2004-07-07 16:18:02 UTC
Foiled by more than one copy of gtk2 in the tree.  *sigh*

Another fix added.


Note You need to log in before you can comment on or make changes to this bug.