Bug 1269048 - Upstart respawn limits changed.
Upstart respawn limits changed.
Status: CLOSED NOTABUG
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Distribution (Show other bugs)
1.3.0
x86_64 Linux
unspecified Severity low
: rc
: 1.3.2
Assigned To: ceph-eng-bugs
ceph-qe-bugs
: Reopened
Depends On:
Blocks: 1253803
  Show dependency treegraph
 
Reported: 2015-10-06 03:07 EDT by shylesh
Modified: 2015-11-20 13:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 13:22:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2015-10-06 03:07:02 EDT
Please refer https://bugzilla.redhat.com/show_bug.cgi?id=1262976#c13 . which will explain why this bug.
Comment 2 shylesh 2015-10-06 04:29:08 EDT
According to https://bugzilla.redhat.com/show_bug.cgi?id=1262976#c6 , upstart shows inconsistent behaviour. Hence this needs to be documented in "know issues" section of release notes for 1.3.0 Ubuntu.
Comment 3 Federico Lucifredi 2015-11-09 20:55:35 EST
The behavior is not inconsistent, just too eager / generous.

Release notes: "The upstart respawn limit has been changed from 5 restarts in 30 seconds to 3 restarts in 30 minutes for the OSD and MON daemons".
Comment 4 Federico Lucifredi 2015-11-09 20:57:52 EST
Actually, this is not a "known issue", it is a change. Carrying this to the release notes directly.
Comment 5 shylesh 2015-11-20 13:13:38 EST
@Federico,

While verifying https://bugzilla.redhat.com/show_bug.cgi?id=1262976 we found this issue which still exists. So I think this bug still should go as "known issue" since behaviour is inconsistent.

Please refer https://bugzilla.redhat.com/show_bug.cgi?id=1262976#c13 . Here it says the actual fix for 1262976 should go as release notes, whereas this bug should goto "known issues" so that it gives clarity to the user about the changes and its side effects.

Reopening this bug ,Let me know your thoughts.
Comment 6 Federico Lucifredi 2015-11-20 13:22:24 EST
Maybe there is an inconsistency in Upstart's behavior, on the point where it reaches saturation (don't know — may be designed to be this way), but it doesn't matter, we don't make Ubuntu here :)

The item we need to document is the changes in our Upstart settings (the other bug). This one is not a Ceph issue, and I don't think we should care to report it against Ubuntu itself they are switching to Systemd as well in 16.04.

Note You need to log in before you can comment on or make changes to this bug.