Bug 1269091 - Flat file import wizard stuck when model project not selected beforehand
Flat file import wizard stuck when model project not selected beforehand
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Barry LaFond
Andrej Smigala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 06:00 EDT by Andrej Smigala
Modified: 2015-11-17 13:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 13:08:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2679 Major Closed Flat file import wizard stuck when model project not selected beforehand 2015-11-17 13:00 EST

  None (edit)
Description Andrej Smigala 2015-10-06 06:00:07 EDT
In some situations, especially when returning from Database Development perspective back to Teiid Designer perspective after executing a VDB, the Import From Flat File Source wizard will fail when selecting the target model location. Even after selecting a model project, the wizard says "Source model file location must be selected. Choose '...' button and select existing project or folder", and cannot be advanced further. See Steps to reproduce for details.

The issue disappears after clicking on a model project in the Model Explorer.

It appears that the wizard tries to use the selected project, but there is none in some situations.

The issue seems to be limited to Flat File import wizard.


Steps to reproduce:
These steps must be followed exactly. There are other situations when this issue occurs, but these are the only steps I was able to find to reliably reproduce.
# open JBDS with clean workspace
# open Teiid Designer perspective
# create new model project
# create a new empty VDB in the project
# expand the project in the Model Explorer, double click the VDB, do *not* click on the project
# select Window -> Open Perspective -> Other -> Database Development
# switch back to Teiid Designer perspective, do *not* click on the project
# switch to Outline
# select File -> Import -> File Source (Flat) 
# Next, Next
# click New, define any flat file datasource, Finish
# under Source Model Definition, the Name is now prefilled, Location is empty
# Click "..." next to Location, select the model project, OK
# notice the wizard still says "Source model file location must be selected. Choose '...' button and select existing project or folder"
Comment 2 JBoss JIRA Server 2015-10-06 18:17:11 EDT
Ted Jones <tejones@redhat.com> updated the status of jira TEIIDDES-2679 to Resolved
Comment 3 JBoss JIRA Server 2015-10-20 05:47:54 EDT
Matus Makovy <mmakovy@redhat.com> updated the status of jira TEIIDDES-2679 to Closed

Note You need to log in before you can comment on or make changes to this bug.