Bug 1269138 - git-daemon does not allow shallow clone from read-only repository
git-daemon does not allow shallow clone from read-only repository
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pstodulk
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1391253
  Show dependency treegraph
 
Reported: 2015-10-06 08:37 EDT by David Woodhouse
Modified: 2016-11-02 17:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1391253 (view as bug list)
Environment:
Last Closed: 2016-07-01 05:44:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2015-10-06 08:37:29 EDT
[dwoodhou@i7 tmp]$ git clone --depth 1 git://git.infradead.org/l2-mtd.git
Cloning into 'l2-mtd'...
fatal: The remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed


Oct  6 05:31:59 bombadil git-daemon[8837]: fatal: Unable to create temporary file '/srv/git/l2-mtd.git/shallow_2E9NkF': Permission denied
Oct  6 05:31:59 bombadil xinetd[7097]: EXIT: git status=128 pid=8837 duration=1(sec)


Perhaps relevant:
http://git.661346.n2.nabble.com/PATCH-upload-pack-allow-shallow-fetching-from-a-read-only-repository-td7604326.html
Comment 1 Fedora Admin XMLRPC Client 2016-03-16 14:23:52 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 pstodulk 2016-07-01 05:44:25 EDT
Hi David,
it works for me with current git (was rebased since report of the bug), so I am closing this, but feel free to reopen if You reproduce again.

Note You need to log in before you can comment on or make changes to this bug.