Bug 1269141 - kworker 100 CPU usage. Workqueue: events e1000e_systim_overflow_work [e1000e]
kworker 100 CPU usage. Workqueue: events e1000e_systim_overflow_work [e1000e]
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 08:45 EDT by javiermon
Modified: 2016-10-17 08:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-17 08:52:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg. (69.39 KB, text/plain)
2015-10-06 08:45 EDT, javiermon
no flags Details

  None (edit)
Description javiermon 2015-10-06 08:45:43 EDT
Created attachment 1080226 [details]
dmesg.

Description of problem:

This is a dell latitude laptop e6530 with fedora 23 x86_64 up to date. Randomly, the laptop becomes sluggish and top reveals process kworker using 100% cpu. On system journal and dmesg I can see a kernel trace:

[14466.867697] ieee80211 phy1: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x0438 with error -110
[14466.978785] ieee80211 phy1: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x0438 with error -110
[14467.126853] ieee80211 phy1: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1700 with error -110
[14525.990306] INFO: rcu_sched detected stalls on CPUs/tasks: { 1} (detected by 2, t=60003 jiffies, g=148918, c=148917, q=0)
[14525.990331] Task dump for CPU 1:
[14525.990339] kworker/1:2     R  running task        0  7312      2 0x00000088
[14525.990374] Workqueue: events e1000e_systim_overflow_work [e1000e]
[14525.990380]  ffff880184be7e28 0000000071245a67 ffff880214b79d80 ffff880063fb1a40
[14525.990389]  ffff880184be7e48 ffffffff810b64fe ffff880235255fc0 0000000000000000
[14525.990396]  0000000000000008 ffff880063fb1a40 ffff880063fb1a70 ffff880235255fc0
[14525.990405] Call Trace:
[14525.990422]  [<ffffffff810b64fe>] ? process_one_work+0x19e/0x3f0
[14525.990432]  [<ffffffff810b679e>] ? worker_thread+0x4e/0x450
[14525.990440]  [<ffffffff810b6750>] ? process_one_work+0x3f0/0x3f0
[14525.990449]  [<ffffffff810b6750>] ? process_one_work+0x3f0/0x3f0
[14525.990457]  [<ffffffff810bc8a8>] ? kthread+0xd8/0xf0
[14525.990465]  [<ffffffff810bc7d0>] ? kthread_worker_fn+0x160/0x160
[14525.990477]  [<ffffffff8177875f>] ? ret_from_fork+0x3f/0x70
[14525.990485]  [<ffffffff810bc7d0>] ? kthread_worker_fn+0x160/0x160


Version-Release number of selected component (if applicable):
kernel-4.2.2-300.fc23.x86_64

How reproducible:
The crash happens very often but at random times.


Please let me know if more information is needed and how I can debug it.

Thanks,
Comment 1 javiermon 2015-10-06 09:10:21 EDT
Last time this happened the laptop was not using ethernet, so I'm not sure why the kernel trace points to e1000e.
Comment 2 Laura Abbott 2016-09-23 15:42:59 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 3 javiermon 2016-10-17 07:17:58 EDT
I've upgraded the laptop to fedora 24 and I haven't experienced this issue anymore. Feel free to close the bug.

Note You need to log in before you can comment on or make changes to this bug.