Bug 1269151 - [abrt] gnome-builder: _g_log_abort(): gnome-builder killed by SIGTRAP
[abrt] gnome-builder: _g_log_abort(): gnome-builder killed by SIGTRAP
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-builder (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David King
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:3962b4fa532b6f3cd5e1bc1945b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 09:12 EDT by Zeeshan Ali
Modified: 2016-09-19 21:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-07 05:06:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (150.73 KB, text/plain)
2015-10-06 09:12 EDT, Zeeshan Ali
no flags Details
File: cgroup (190 bytes, text/plain)
2015-10-06 09:12 EDT, Zeeshan Ali
no flags Details
File: core_backtrace (24.96 KB, text/plain)
2015-10-06 09:12 EDT, Zeeshan Ali
no flags Details
File: dso_list (22.28 KB, text/plain)
2015-10-06 09:12 EDT, Zeeshan Ali
no flags Details
File: environ (962 bytes, text/plain)
2015-10-06 09:12 EDT, Zeeshan Ali
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-06 09:12 EDT, Zeeshan Ali
no flags Details
File: maps (96.18 KB, text/plain)
2015-10-06 09:12 EDT, Zeeshan Ali
no flags Details
File: mountinfo (3.21 KB, text/plain)
2015-10-06 09:12 EDT, Zeeshan Ali
no flags Details
File: namespaces (85 bytes, text/plain)
2015-10-06 09:12 EDT, Zeeshan Ali
no flags Details
File: open_fds (848 bytes, text/plain)
2015-10-06 09:12 EDT, Zeeshan Ali
no flags Details
File: proc_pid_status (1015 bytes, text/plain)
2015-10-06 09:13 EDT, Zeeshan Ali
no flags Details
File: var_log_messages (247 bytes, text/plain)
2015-10-06 09:13 EDT, Zeeshan Ali
no flags Details

  None (edit)
Description Zeeshan Ali 2015-10-06 09:12:28 EDT
Description of problem:
I get this every time on launching the app.

Version-Release number of selected component:
gnome-builder-3.18.0-1.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/bin/gnome-builder --gapplication-service
crash_function: _g_log_abort
executable:     /usr/bin/gnome-builder
global_pid:     13424
kernel:         4.2.2-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 _g_log_abort at gmessages.c:324
 #10 _cairo_xlib_display_sync at cairo-xlib-surface-shm.c:461
 #11 _cairo_xlib_surface_update_shm at cairo-xlib-surface-shm.c:952
 #12 _cairo_xlib_surface_get_shm at cairo-xlib-surface-shm.c:1045
 #13 _cairo_xlib_surface_acquire_source_image at cairo-xlib-surface.c:1394
 #14 _cairo_surface_acquire_source_image at cairo-surface.c:1973
 #15 _pixman_image_for_surface at cairo-image-source.c:1377
 #16 _pixman_image_for_pattern at cairo-image-source.c:1538
 #17 _cairo_image_source_create_for_pattern at cairo-image-source.c:1583
 #18 composite_aligned_boxes at cairo-spans-compositor.c:678
Comment 1 Zeeshan Ali 2015-10-06 09:12:37 EDT
Created attachment 1080229 [details]
File: backtrace
Comment 2 Zeeshan Ali 2015-10-06 09:12:39 EDT
Created attachment 1080230 [details]
File: cgroup
Comment 3 Zeeshan Ali 2015-10-06 09:12:42 EDT
Created attachment 1080231 [details]
File: core_backtrace
Comment 4 Zeeshan Ali 2015-10-06 09:12:45 EDT
Created attachment 1080232 [details]
File: dso_list
Comment 5 Zeeshan Ali 2015-10-06 09:12:46 EDT
Created attachment 1080233 [details]
File: environ
Comment 6 Zeeshan Ali 2015-10-06 09:12:48 EDT
Created attachment 1080234 [details]
File: limits
Comment 7 Zeeshan Ali 2015-10-06 09:12:53 EDT
Created attachment 1080235 [details]
File: maps
Comment 8 Zeeshan Ali 2015-10-06 09:12:55 EDT
Created attachment 1080236 [details]
File: mountinfo
Comment 9 Zeeshan Ali 2015-10-06 09:12:57 EDT
Created attachment 1080237 [details]
File: namespaces
Comment 10 Zeeshan Ali 2015-10-06 09:12:58 EDT
Created attachment 1080238 [details]
File: open_fds
Comment 11 Zeeshan Ali 2015-10-06 09:13:00 EDT
Created attachment 1080239 [details]
File: proc_pid_status
Comment 12 Zeeshan Ali 2015-10-06 09:13:02 EDT
Created attachment 1080240 [details]
File: var_log_messages
Comment 13 Zeeshan Ali 2015-10-13 14:22:24 EDT
Just to point out that this could be caused by the list of repos at launch being way too big. If i launch with a repo dir argument from commandline, Builder works fine.
Comment 14 Igor Gnatenko 2016-07-07 05:06:18 EDT
This is very old bug, if you still can reproduce it - please reopen.

Note You need to log in before you can comment on or make changes to this bug.