This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1269163 - deleting a lifecycle environment from a capsule should free up space below /var/lib/pulp
deleting a lifecycle environment from a capsule should free up space below /v...
Status: CLOSED DUPLICATE of bug 1111223
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule (Show other bugs)
6.1.2
All Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 09:39 EDT by Christian Horn
Modified: 2017-04-25 12:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-07 09:01:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Horn 2015-10-06 09:39:13 EDT
Description of problem:
deleting a lifecycle environment from a capsule does not free up space below /var/lib/pulp.  On a satellite, a weekly cronjob calls "foreman-rake katello:delete_orphaned_content" for this (see https://access.redhat.com/solutions/1276263 ), but installing foreman-rake is considered to heavy for a capsule.

Version-Release number of selected component (if applicable):
sat 6.1.2

How reproducible:
always

Steps to Reproduce:
1. remove a livecycle environment from a capule as per https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/User_Guide/sect-Red_Hat_Satellite-User_Guide-Removing_Life_Cycle_Environments_from_the_Red_Hat_Satellite_Capsule_Server.html
2. du -sk /var/lib/pulp

Actual results:
/var/lib/pulp should get smaller

Expected results:
size stays the same

Additional info:
Comment 3 Bryan Kearney 2016-07-08 16:22:17 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 5 Justin Sherrill 2016-09-07 09:01:14 EDT

*** This bug has been marked as a duplicate of bug 1111223 ***

Note You need to log in before you can comment on or make changes to this bug.