Bug 1269182 - hosted-engine accepts FQDNs with underscore while the engine correctly fails on that
hosted-engine accepts FQDNs with underscore while the engine correctly fails ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
1.2.4
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.1
: 1.3.1
Assigned To: Rafael Martins
Nikolai Sednev
: EasyFix, ZStream
Depends On: 1221176
Blocks: 1284979
  Show dependency treegraph
 
Reported: 2015-10-06 10:35 EDT by Sandro Bonazzola
Modified: 2016-02-17 02:39 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
"hosted-engine --deploy" used to accept FQDNs with underscores, that are invalid and were already refused by "engine-setup". "hosted-engine --deploy" now refuses FQDNs with undescores as well.
Story Points: ---
Clone Of: 1221176
Environment:
Last Closed: 2016-02-17 02:39:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
sherold: planning_ack+
sbonazzo: devel_ack+
istein: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46823 None None None Never
oVirt gerrit 46986 ovirt-hosted-engine-setup-1.3 MERGED packaging: setup: do not accept '_' character in FQDN Never
oVirt gerrit 46987 None None None Never
oVirt gerrit 47784 ovirt-hosted-engine-setup-1.3 MERGED packaging: setup: validate full fqdn Never

  None (edit)
Description Sandro Bonazzola 2015-10-06 10:35:13 EDT
+++ This bug was initially created as a clone of Bug #1221176 +++

Description of problem:
ovirt-hosted-engine-setup doesn't complain trying to deploy on an host with '_' in its name while the engine than correctly refuse to add the host not validating its name.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup.noarch       1.2.4-0.0.master.20150513073740.git86111d0.el7

How reproducible:


Steps to Reproduce:
1. set an hostname with '_' in the name
2. launch hosted-engine --deploy
3.

Actual results:
It accepts the wrong hostname

Expected results:
It should complain about the hostname being invalid due to RFC952


Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:56:24 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Gil Klein 2016-02-17 02:39:18 EST
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.