Bug 1269187 - [vdsm] Domain deactivation doesn't clear domain from the domains to be upgraded list
[vdsm] Domain deactivation doesn't clear domain from the domains to be upgrad...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.1
All Linux
unspecified Severity high
: ovirt-3.5.6
: 3.5.6
Assigned To: Liron Aravot
Elad
storage
: ZStream
Depends On: 1260429
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 11:09 EDT by rhev-integ
Modified: 2016-02-10 13:11 EST (History)
26 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1260429
Environment:
Last Closed: 2015-12-01 15:40:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45773 master MERGED sp: deactivateSd - remove domain from pending for upgrade list Never
oVirt gerrit 45866 master MERGED hsm: lock pool when running upgradeStoragePool Never
oVirt gerrit 45967 ovirt-3.6 MERGED hsm: lock pool when running upgradeStoragePool Never
oVirt gerrit 45968 ovirt-3.6 MERGED sp: deactivateSd - remove domain from pending for upgrade list Never
oVirt gerrit 45977 ovirt-3.5 MERGED hsm: lock pool when running upgradeStoragePool Never
oVirt gerrit 45978 ovirt-3.5 MERGED sp: deactivateSd - remove domain from pending for upgrade list Never

  None (edit)
Comment 2 Aharon Canan 2015-11-09 08:32:38 EST
Verified using vt18.2

Verification steps 
==================
1. Create new 3.4 DC, 3.5 Cluster, Add new host
2. Add 2 new storage domains to DC (ISCSI and NFS) 
3. Move host to maintenance
4. block connection between the host and the non master domain (NFS)
5. activate the host, wait for it to become the spm
6. Enter blocked domain to maintenance.
7. Upgrade the DC to 3.5 .

Actual results:
DC upgraded to 3.5
Comment 4 errata-xmlrpc 2015-12-01 15:40:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2530.html

Note You need to log in before you can comment on or make changes to this bug.