Bug 1269206 - Errors in attach disk to VM window (scrolling error and selection errors)
Errors in attach disk to VM window (scrolling error and selection errors)
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Tal Nisan
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 11:50 EDT by Tal Nisan
Modified: 2016-03-10 02:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 09:37:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
Before scrolling (77.79 KB, image/png)
2015-10-06 11:50 EDT, Tal Nisan
no flags Details
After scrolling (73.10 KB, image/png)
2015-10-06 11:50 EDT, Tal Nisan
no flags Details
screenshot (87.16 KB, image/png)
2016-01-03 08:45 EST, Aharon Canan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47048 master MERGED webadmin: Fix scrolling in attach disk panel Never
oVirt gerrit 47093 ovirt-engine-3.6 MERGED webadmin: Fix scrolling in attach disk panel Never

  None (edit)
Description Tal Nisan 2015-10-06 11:50:05 EDT
Created attachment 1080300 [details]
Before scrolling

Description of problem:
When trying to attach a disk to VM and having more than one page of disks (~18 disks and more) we encounter two problems:
1. When scrolling the disk list in attach disk to VM window, the table header are scrolled up instead of remaining static on the top
2. When trying to select the disks at the lower part of the table they are unclickable

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Have more than 18 floating disks (or shareable)
2. Click on a VM
3. Click 'Attach'
Comment 1 Tal Nisan 2015-10-06 11:50 EDT
Created attachment 1080301 [details]
After scrolling
Comment 2 Yaniv Lavi (Dary) 2015-10-29 08:36:58 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Aharon Canan 2016-01-03 08:45 EST
Created attachment 1111167 [details]
screenshot

Failed

vdsm-4.17.15-0.el7ev.noarch
rhevm-3.6.2-0.1.el6.noarch

Steps to Reproduce:
1. Create 18 floating disks
2. Create a VM
3. Under VM (disk subtab) Click 'Attach'

When scrolling the disk list in attach disk to VM window, the table header are scrolled up instead of remaining static on the top - screenshot attached
Comment 4 Red Hat Bugzilla Rules Engine 2016-01-03 08:46:01 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Tal Nisan 2016-01-03 09:43:42 EST
Aharon, the header I was referring to that was disappearing before my fix was the green header with the "Image/Direct LUN/Cinder" selector and this was indeed fixed as it stays intact upon scrolling.
The header that disappears is the one of the disks table with the column names and this is a general infrastructure problem which was not addressed in this bug.
Comment 6 Aharon Canan 2016-01-03 09:46:57 EST
Verified.

Do we have a bug for the general infrastructure problem?
Comment 7 Tal Nisan 2016-01-03 10:52:09 EST
Couldn't find one although derez and I are quite sure there was one, in any way, it's a known issue
Comment 8 Sandro Bonazzola 2016-01-13 09:37:25 EST
oVirt 3.6.1 has been released, closing current release

Note You need to log in before you can comment on or make changes to this bug.