Bug 1269210 - While Power off in GNOME 3.18 -> Xorg killed by SIGABRT
Summary: While Power off in GNOME 3.18 -> Xorg killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedFreezeException
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-06 16:27 UTC by sangu
Modified: 2015-11-01 02:37 UTC (History)
6 users (show)

Fixed In Version: xorg-x11-server-1.18.0-0.5.20150907.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-01 02:37:09 UTC


Attachments (Terms of Use)

Description sangu 2015-10-06 16:27:05 UTC
Description of problem:
$$ coredumpctl gdb Xorg
           PID: 1773 (Xorg)
           UID: 1000 (sangu)
           GID: 1000 (sangu)
        Signal: 6 (ABRT)
     Timestamp: 화 2015-10-06 01:48:36 KST (23h ago)
  Command Line: /usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
    Executable: /usr/libexec/Xorg
 Control Group: /user.slice/user-1000.slice/session-1.scope
          Unit: session-1.scope
         Slice: user-1000.slice
       Session: 1
     Owner UID: 1000 (sangu)
       Boot ID: 8c1dcb7c077041e18b9e5e7c941e439c
    Machine ID: 1d6c0776def0448e9f708cb1a1a29af1
      Hostname: localhost
      Coredump: /var/lib/systemd/coredump/core.Xorg.1000.8c1dcb7c077041e18b9e5e7c941e439c.1773.1444063716000000.xz
       Message: Process 1773 (Xorg) of user 1000 dumped core.
                
                Stack trace of thread 1773:
                #0  0x00007f8fd1c6ca98 raise (libc.so.6)
                #1  0x00007f8fd1c6e69a abort (libc.so.6)
                #2  0x000000000059d48e OsAbort (Xorg)
                #3  0x00000000005a3e77 FatalError (Xorg)
                #4  0x000000000049d721 switch_to (Xorg)
                #5  0x000000000049e103 xf86CloseConsole (Xorg)
                #6  0x0000000000479305 ddxGiveUp (Xorg)
                #7  0x00000000005a3072 AbortServer (Xorg)
                #8  0x00000000005a3ead FatalError (Xorg)
                #9  0x000000000049d721 switch_to (Xorg)
                #10 0x000000000049e103 xf86CloseConsole (Xorg)
                #11 0x0000000000479305 ddxGiveUp (Xorg)
                #12 0x000000000043aab9 dix_main (Xorg)
                #13 0x00007f8fd1c58580 __libc_start_main (libc.so.6)
                #14 0x0000000000424b79 _start (Xorg)
                
                Stack trace of thread 1868:
                #0  0x00007f8fd1a27b10 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
                #1  0x00007f8fcc8f6f99 __run__ (intel_drv.so)
                #2  0x00007f8fd1a2260a start_thread (libpthread.so.0)
                #3  0x00007f8fd1d3abbd __clone (libc.so.6)
                
                Stack trace of thread 1866:
                #0  0x00007f8fd1a27b10 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
                #1  0x00007f8fcc8f6f99 __run__ (intel_drv.so)
                #2  0x00007f8fd1a2260a start_thread (libpthread.so.0)
                #3  0x00007f8fd1d3abbd __clone (libc.so.6)
                
                Stack trace of thread 1867:
                #0  0x00007f8fd1a27b10 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
                #1  0x00007f8fcc8f6f99 __run__ (intel_drv.so)
                #2  0x00007f8fd1a2260a start_thread (libpthread.so.0)
                #3  0x00007f8fd1d3abbd __clone (libc.so.6)

GNU gdb (GDB) Fedora 7.10-23.fc23

Core was generated by `/usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -noliste'.
Program terminated with signal SIGABRT, Aborted.
#0  0x00007f8fd1c6ca98 in __GI_raise (sig=sig@entry=6)
    at ../sysdeps/unix/sysv/linux/raise.c:55
55	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);

(gdb) bt
#0  0x00007f8fd1c6ca98 in __GI_raise (sig=sig@entry=6)
    at ../sysdeps/unix/sysv/linux/raise.c:55
#1  0x00007f8fd1c6e69a in __GI_abort () at abort.c:89
#2  0x000000000059d48e in OsAbort () at utils.c:1377
#3  0x00000000005a3e77 in FatalError (
    f=f@entry=0x5b5f74 "%s: VT_ACTIVATE failed: %s\n") at log.c:948
#4  0x000000000049d721 in switch_to (vt=2, from=0x5b5ffd "xf86CloseConsole")
    at lnx_init.c:73
#5  0x000000000049e103 in xf86CloseConsole () at lnx_init.c:349
#6  0x0000000000479305 in ddxGiveUp (error=error@entry=EXIT_ERR_ABORT)
    at xf86Init.c:1068
#7  0x00000000004793ba in AbortDDX (error=error@entry=EXIT_ERR_ABORT)
    at xf86Init.c:1121
#8  0x00000000005a3072 in AbortServer () at log.c:804
#9  0x00000000005a3ead in FatalError (
    f=f@entry=0x5b5f74 "%s: VT_ACTIVATE failed: %s\n") at log.c:945
#10 0x000000000049d721 in switch_to (vt=2, from=0x5b5ffd "xf86CloseConsole")
    at lnx_init.c:73
#11 0x000000000049e103 in xf86CloseConsole () at lnx_init.c:349
#12 0x0000000000479305 in ddxGiveUp (error=error@entry=EXIT_NO_ERROR)
    at xf86Init.c:1068
#13 0x000000000043aab9 in dix_main (argc=14, argv=0x7ffe42629b88, 
    envp=<optimized out>) at main.c:380
---Type <return> to continue, or q <return> to quit---
#14 0x00007f8fd1c58580 in __libc_start_main (main=0x424b40 <main>, argc=14, 
    argv=0x7ffe42629b88, init=<optimized out>, fini=<optimized out>, 
    rtld_fini=<optimized out>, stack_end=0x7ffe42629b78) at libc-start.c:289
#15 0x0000000000424b79 in _start ()

Version-Release number of selected component (if applicable):
1.18.0-0.4.20150907.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1. Power OFF in gnome system status menu
2.
3.

Actual results:


Expected results:


Additional info:
GNOME 3.18
gnome-shell-3.18.0-1.fc23.x86_64
gdm-3.18.0-1.fc23.x86_64

Comment 1 Stefan 2015-10-12 18:33:37 UTC
Same problem here.

if I shutdown my Fedora 23, then the monitor lost the signal, but the computer doesn't power off anymore. It worked in the first days of Fedora 23 beta, but since 30. September, it's broken.

One of the last log entries is Process 1358 (Xorg) of user 1000 dumped core.


Okt 11 19:37:22 pc gdm[1211]: GLib: g_hash_table_find: assertion 'version == hash_table->version' failed
Okt 11 19:37:22 pc systemd[1]: Stopped GNOME Display Manager.
Okt 11 19:37:22 pc audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=gdm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=
Okt 11 19:37:22 pc systemd[1]: Starting Show Plymouth Power Off Screen...
Okt 11 19:37:22 pc systemd[1]: Stopping LSB: Init script for live image....
Okt 11 19:37:22 pc systemd[1]: Stopped LSB: Init script for live image..
Okt 11 19:37:22 pc audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=livesys comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? 
Okt 11 19:37:22 pc vboxdrv.sh[2477]: Stopping VirtualBox kernel modules [  OK  ]
Okt 11 19:37:22 pc systemd[1]: Stopped VirtualBox Linux kernel module.
Okt 11 19:37:22 pc audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=vboxdrv comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? 
Okt 11 19:37:22 pc systemd[1]: Received SIGRTMIN+20 from PID 2506 (plymouthd).
Okt 11 19:37:22 pc systemd[1]: Started Show Plymouth Power Off Screen.
Okt 11 19:37:22 pc audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=plymouth-poweroff comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? 
Okt 11 19:37:26 pc systemd-coredump[2496]: Process 1358 (Xorg) of user 1000 dumped core.
                                           
                                           Stack trace of thread 1358:
                                           #0  0x00007fc8cf268a98 raise (libc.so.6)
                                           #1  0x00007fc8cf26a69a abort (libc.so.6)
                                           #2  0x000000000059d48e OsAbort (Xorg)
                                           #3  0x00000000005a3e77 FatalError (Xorg)
                                           #4  0x000000000049d721 switch_to (Xorg)
                                           #5  0x000000000049e103 xf86CloseConsole (Xorg)
                                           #6  0x0000000000479305 ddxGiveUp (Xorg)
                                           #7  0x00000000005a3072 AbortServer (Xorg)
                                           #8  0x00000000005a3ead FatalError (Xorg)
                                           #9  0x000000000049d721 switch_to (Xorg)
                                           #10 0x000000000049e103 xf86CloseConsole (Xorg)
                                           #11 0x0000000000479305 ddxGiveUp (Xorg)
                                           #12 0x000000000043aab9 dix_main (Xorg)
                                           #13 0x00007fc8cf254580 __libc_start_main (libc.so.6)
                                           #14 0x0000000000424b79 _start (Xorg)
Okt 11 19:37:31 pc gnome-keyring-daemon[1568]: couldn't set environment variable in session: Timeout was reached
-- Reboot --
Okt 11 19:39:45 pc systemd-journal[163]: Runtime journal is using 8.0M (max allowed 394.9M, trying to leave 592.4M free of 3.8G available → current limit 394.9M).
Okt 11 19:39:45 pc systemd-journal[163]: Runtime journal is using 8.0M (max allowed 394.9M, trying to leave 592.4M free of 3.8G available → current limit 394.9M).

Comment 2 Hans de Goede 2015-10-14 14:07:14 UTC
Thanks for the bug report, I believe that I've figured out what is going on and I've a fix ready for testing, it should show up in updates-testing soon. Please let me know if it fixes things for you.

Comment 3 Fedora Update System 2015-10-15 06:33:11 UTC
xorg-x11-server-1.18.0-0.5.20150907.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-429ee14b69

Comment 4 Fedora Update System 2015-10-15 20:54:14 UTC
xorg-x11-server-1.18.0-0.5.20150907.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xorg-x11-server'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-429ee14b69

Comment 5 Stefan 2015-10-16 17:56:16 UTC
After the update - it works

Comment 6 Fedora Blocker Bugs Application 2015-10-16 19:06:41 UTC
Proposed as a Freeze Exception for 23-final by Fedora user pwalter using the blocker tracking app because:

 Several people have reported a similar crash. Would be good to include the fix in the final release.

Comment 7 Adam Williamson 2015-10-19 20:43:40 UTC
-1 FE, I think, not good to change X server this late, and we can fix it with an update.

Comment 8 Stephen Gallagher 2015-10-19 20:45:15 UTC
-1 FE, too much risk mucking with X during Final Freeze.

Comment 9 Kevin Fenzi 2015-10-19 20:45:31 UTC
Yeah, -1 FE

Comment 10 Mike Ruckman 2015-10-19 20:46:44 UTC
I concur. -1 FE

Comment 11 Adam Williamson 2015-10-19 20:49:38 UTC
That's -4 FE, rejected.

Comment 12 Fedora Update System 2015-11-01 02:37:05 UTC
xorg-x11-server-1.18.0-0.5.20150907.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.