Bug 126923 - intel 845 gfx card hangs with vertical color lines on cold boot
intel 845 gfx card hangs with vertical color lines on cold boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-29 00:39 EDT by entheon
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-05 17:16:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description entheon 2004-06-29 00:39:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I have updated the bios as per the instructions for a documented bug
concerning the 8MB apperture of the video card, it was one of the
first things I did and xinit worked fine for a long time. But now it
seems to have problems.

Note: I am experiencing similar problems with Windows - minor video
corruption on widgets and text panels. Even corrupt/screwy looking
window widgets still work (if one can discern what widget is what!)
but this is annoying as hell. Seems random what portion of the
screen/window gets corrupted but also seems consistent between apps.
As in the toolbar routinely garbles with IE and the left folder tree
pane corrupts with Windows Explorer, Steinberg CubaseVST usually
corrupts along the top portion of the window, etc etc or the "start
menu" icon/logo is often corrupt.

I've been experiencing this problem for a while and I did a little
research online already and I've browsed through this bugzilla DB but
I've found nothing close to this (hang with vertical color bars)
except the already documented "845" patch which is rendered obsolete
by the A29 bios update. I've also come across the X hangs on switch
between virtual terminal and X but it was not often reproducable and
switching between X and VT's has not hung since the early days when I
first installed fedora.

My guess - because this is affecting both my windows and linux
installs - is that there is something majorly wrong with the gfx card
in this machine but I can't find any concrete data or evidence to
support the notion. Does anyone know of inconsistencies between the
i830 DRM kernel module and XFree86 v4.3?

I was desperate at first cause all my data/projects/code is on linux
and it just wouldn't budge at all once it hung on the color lines but
I've since discovered that a warm reboot from windows seems to "fix"
this problem, however if I ever forget to warm boot from windows linux
gives me it's usual fancy dancy useless vertical color bars and no way
to escape to a VT or anything. Then I cold reboot into windows and
then warm reboot into linux and viola... presto chango the no more
colored linezo. WTF is up w/this? it's drivin me nuts! 

Thanks all, aloha.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-55

How reproducible:
Always

Steps to Reproduce:
1. Cold boot into linux
2. Force halt w/power button and boot WindowsXP
3. Warm reboot into linux
    

Actual Results:  after 1) linux boots fine until X tries to initialize
the display at which point it hangs fully on a black screen with the
top left quadrant of the screen filled with colored vertical lines.
Cannot switch to virtual terminals (at least one of which I can see
pop onto the screen right before X tries to init) using <ALT-F1>
through <ALT-F6> and cannot force quit the X server with
<CTL-ALT-Backspace>

after 2) things are "normal" in the windoze stylie

after 3) x boots like normal and I login w/gdm - just like nothin happened

Expected Results:  the x-server should have initialized like normal,
like the other hundred or so times that I've booted it in the past
without problems - it's only within the past weeks that this has
happened to me and I've been using this fedora system for longer than
that and it worked fine after fresh install.

Additional info:

SYSTEM
=========================================
Dell Inspiron 1100 - Laptop

CPU: Intel pentium 4 2.3GHz
BIOS: A29
Video: Intel Corp. 82845G/GL (shared memory)
Sound: Intel 82801DB AC'97 Audio
Netwk: Broadcom 4400
USB
CDRW
LCD
Comment 1 Mike A. Harris 2004-07-05 17:16:16 EDT
You mention that you are experiencing a similar problem in both
Windows and Linux.  Normally I would conclude it to be a hardware
problem such as bad video memory or similar, however you also
mention it only occurs after the video BIOS update, so it is just
as likely to be a BIOS bug introduced with the BIOS update.

Since Intel video hardware uses the system RAM for video, you may
be able to test this by setting the onboard memory to the smallest
amount and running memtest86 to test your system memory, however
that may be inconclusive.

The most important observation though is that the failures are in
Windows as well.  That definitely points to it being a video hardware
or firmware issue of some kind.  I recommend contacting your
motherboard vendor about this problem and getting a new BIOS update
when one comes available, or putting the original BIOS back for now.

Hardware issue - closing as "NOTABUG"

Note You need to log in before you can comment on or make changes to this bug.