Bug 1269232 - sssd crashes if non-UTF-8 locale is used
sssd crashes if non-UTF-8 locale is used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Slebodnik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1278566
  Show dependency treegraph
 
Reported: 2015-10-06 14:20 EDT by Terje Røsten
Modified: 2015-11-30 18:22 EST (History)
9 users (show)

See Also:
Fixed In Version: sssd-1.13.2-1.fc23 sssd-1.13.2-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1278566 (view as bug list)
Environment:
Last Closed: 2015-11-26 15:58:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Røsten 2015-10-06 14:20:42 EDT
Description of problem:

Since sssd 1.13 has been crashing, downgrading to 1.12, seems to solve the problem. 

I get the following trace:
 
    Stack trace of thread 8379:
                                                              #0  0x00007fac4d7d2a98 raise (libc.so.6)
                                                              #1  0x00007fac4d7d469a abort (libc.so.6)
                                                              #2  0x00007fac5168d3b4 _dbus_abort (libdbus-1.so.3)
                                                              #3  0x00007fac51683e3e _dbus_warn_check_failed (libdbus-1.so.3)
                                                              #4  0x00007fac51675d96 dbus_message_iter_append_basic (libdbus-1.so.3)
                                                              #5  0x00007fac51676698 dbus_message_append_args_valist (libdbus-1.so.3)
                                                              #6  0x00007fac51d1c329 sbus_request_return_and_finish (libsss_util.so)
                                                              #7  0x000055865389b3f3 acctinfo_callback (sssd_be)
                                                              #8  0x00007fac427e0d19 sdap_account_info_complete (libsss_ldap_common.so)
                                                              #9  0x00007fac427ddfe0 users_get_done (libsss_ldap_common.so)
                                                              #10 0x00007fac4df7c1c2 _tevent_req_error (libtevent.so.0)
                                                              #11 0x00007fac4df7c1c2 _tevent_req_error (libtevent.so.0)
                                                              #12 0x00007fac427f6314 sdap_search_user_process (libsss_ldap_common.so)
                                                              #13 0x00007fac427f137c generic_ext_search_handler.isra.3 (libsss_ldap_common.so)
                                                              #14 0x00007fac427f2ee3 sdap_get_generic_op_finished (libsss_ldap_common.so)
                                                              #15 0x00007fac427f22fd sdap_process_result (libsss_ldap_common.so)
                                                              #16 0x00007fac4df803c3 epoll_event_loop_once (libtevent.so.0)
                                                              #17 0x00007fac4df7e907 std_event_loop_once (libtevent.so.0)
                                                              #18 0x00007fac4df7b11d _tevent_loop_once (libtevent.so.0)
                                                              #19 0x00007fac4df7b2bb tevent_common_loop_wait (libtevent.so.0)
                                                              #20 0x00007fac4df7e8a7 std_event_loop_wait (libtevent.so.0)
                                                              #21 0x00007fac51d21fd3 server_loop (libsss_util.so)
                                                              #22 0x000055865389ab76 main (sssd_be)
                                                              #23 0x00007fac4d7be580 __libc_start_main (libc.so.6)
                                                              #24 0x000055865389ac09 _start (sssd_be)


Version-Release number of selected component (if applicable):

sssd-1.13.0-7.fc23.x86_64

How reproducible:

Config sssd with something like this:

[sssd]
config_file_version = 2
reconnection_retries = 3
sbus_timeout = 30
services = nss, pam, autofs
domains = default

[nss]
filter_groups = root
filter_users = root
reconnection_retries = 3

[pam]
reconnection_retries = 3
[domain/default]
auth_provider = ldap
ldap_tls_reqcert = never
ldap_id_use_start_tls = True
cache_credentials = True
ldap_search_base = dc=foo,dc=bar
krb5_realm = EXAMPLE.COM
chpass_provider = ldap
id_provider = ldap
use_fully_qualified_names = False
store_legacy_passwords = False
debug_level = 0
min_id = 100
ldap_uri = ldap://example.com
enumerate = True
autofs_provider = ldap

ldap_tls_cacertdir = /etc/openldap/cacerts
[autofs]

and enable sssd in authconfig.

Start sssd service and wait for crash.
Comment 1 Jakub Hrozek 2015-10-06 14:42:20 EDT
Can you please also upload the logs and the corefile?
Comment 2 Terje Røsten 2015-10-06 14:44:36 EDT
where do I find the core file? 

Anything I need to config to get core file from sssd?
Comment 3 Jakub Hrozek 2015-10-06 15:13:37 EDT
abrt should help you with that, abrt-cli might print where the corefiles are. Normally they're at /var/spool/abrt/ IIRC.

But since we switched to calling setuid and drop privileges, the corefiles might not be generated automatically. In that case, you can attach gdb as described here:
https://fedorahosted.org/sssd/wiki/Reporting_sssd_bugs

How to get debug files is described here:
https://fedorahosted.org/sssd/wiki/Troubleshooting
Comment 4 Terje Røsten 2015-10-06 15:21:48 EDT
Thanks, I have removed all abrt* packages any way, let me see what I can out from gdb.
Comment 5 Lukas Slebodnik 2015-10-08 04:31:08 EDT
(In reply to Terje Røsten from comment #4)
> Thanks, I have removed all abrt* packages any way, let me see what I can out
> from gdb.

You should be able t obtain coredump even without abrt.
You might take a look into coredumpctl[1]. If you didn't change core_pattern manually.

[root@host ~]# cat /proc/sys/kernel/core_pattern
|/usr/lib/systemd/systemd-coredump %p %u %g %s %t %e

[1] http://www.freedesktop.org/software/systemd/man/coredumpctl.html

If you are able to reproduce crash. We might also try to run sssd with valgrind.
Comment 6 Jakub Hrozek 2015-10-08 16:58:34 EDT
In general Terje, please let us know if we can help reproduce the issue or get the core file!
Comment 7 Jakub Hrozek 2015-10-14 10:01:09 EDT
ping?

Can we help you get the debug information?
Comment 8 Lukas Slebodnik 2015-10-30 16:45:39 EDT
It seems to be related to your locales.
I was able to reproduce with setting locales to "norwegian" 

So the workaround is to add line "LANG=C" to the /etc/sysconfig/sssd.
Comment 9 Terje Røsten 2015-10-31 04:55:27 EDT
So far so good, thanks guys!
Comment 10 Lukas Slebodnik 2015-11-05 08:29:07 EST
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2861
Comment 11 Jakub Hrozek 2015-11-14 07:41:17 EST
Fixed upstream:

master:
    6b01dae732eedee808f32a9cdd4b5656a9f839c4
    e8ae3af6724164048a85c374ea8045a368a2d34e
    8bc6bc6d87127d615f7a81d7151cb46007feff63 
sssd-1-13:
    620b2adf7c19c1b9abc456c37926d77649d262b7
    518c003f3d555a525fe3aebf60366e0c0716eff4
    b51ed15a72a3c8542f3dab72158aeee1d7254341
Comment 12 Fedora Update System 2015-11-20 06:10:59 EST
sssd-1.13.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f779615d41
Comment 13 Fedora Update System 2015-11-20 06:12:20 EST
sssd-1.13.2-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-546a9345da
Comment 14 Fedora Update System 2015-11-21 12:52:40 EST
sssd-1.13.2-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update sssd'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-546a9345da
Comment 15 Fedora Update System 2015-11-22 09:26:32 EST
sssd-1.13.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update sssd'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f779615d41
Comment 16 Fedora Update System 2015-11-26 15:58:21 EST
sssd-1.13.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-11-30 18:22:39 EST
sssd-1.13.2-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.