Bug 1269253 - [Docs]Need to specify clearly in documentation that Erasure-coded pools and cache tiering is unsupported
[Docs]Need to specify clearly in documentation that Erasure-coded pools and c...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
1.3.0
Unspecified Linux
unspecified Severity medium
: rc
: 1.3.2
Assigned To: ceph-docs@redhat.com
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 15:40 EDT by Mike Hackett
Modified: 2015-12-18 05:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 05:07:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Hackett 2015-10-06 15:40:24 EDT
Description of problem:
The 1.3 Ceph Storage strategies documentation states:
https://access.redhat.com/documentation/en/red-hat-ceph-storage/version-1.3/red-hat-ceph-storage-13-storage-strategies/#erasure-code
_____________________________________________________________________________
Chapter 30. Erasure-coded Pools and Cache Tiering

Erasure coded pools require more resources than replicated pools and lack some functionality such as partial writes. To overcome these limitations, we recommend to set a cache tier before setting the erasure-coded pool.

For instance, if the pool hot-storage is made of fast storage:

$ ceph osd tier add ecpool hot-storage
$ ceph osd tier cache-mode hot-storage writeback
$ ceph osd tier set-overlay ecpool hot-storage

will place the hot-storage pool as tier of ecpool in writeback mode so that every write and read to the ecpool are actually using the hot-storage and benefit from its flexibility and speed.

It is not possible to create an RBD image on an erasure coded pool because it requires partial writes. It is however possible to create an RBD image on an erasure coded pools when a replicated pool tier set a cache tier:

$ rbd --pool ecpool create --size 10 myvolume
_______________________________________________________________________________

This documentation needs to clearly state that cache tiering is a tech-review feature and will not be supported in production.
Comment 6 Anjana Suparna Sriram 2015-12-18 05:07:01 EST
Fixed in 1.3.2 release.

Note You need to log in before you can comment on or make changes to this bug.