Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1269254 - During $evm.root['miq_provision'] vm.storage_name returns NIL. VM.Storage.Name is required for customer POC involving VMware VIX library.
Summary: During $evm.root['miq_provision'] vm.storage_name returns NIL. VM.Storage...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.4.0
Hardware: All
OS: All
medium
medium
Target Milestone: GA
: 5.5.0
Assignee: Greg McCullough
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-06 19:41 UTC by Josh Carter
Modified: 2015-11-11 20:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-12 20:43:23 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Josh Carter 2015-10-06 19:41:20 UTC
During $evm.root['miq_provision']   vm.storage_name returns NIL.   VM.Storage.Name is required for customer POC involving VMware VIX library.

 

Current work-around is to force evm.refresh during a Power-On Event.

 

VSphere 5.5 Update 2

 

Version-Release number of selected component (if applicable):

 

5.4

 

 

How reproducible:

 

Occurs 3 out of five times.   (Really noticed this in VSPHERE 5.5 vs. VSPHERE 5.1 but could be coincident.)

 

Steps to Reproduce:

1.

2.

3.

 

Actual results:

 

 

Expected results:

 

 

Additional info:

Comment 2 Greg McCullough 2015-10-12 13:52:54 UTC
The Core refresh only populates a few values for a VM (name, IP, power state, etc) but the relationship to storage is not part of that process.  A full or targeted refresh would populate the full data about a VM.

The suggested resolution here would be to retry during the CheckProvisioned or later state waiting for the storage name to be populated.

Comment 3 Greg McCullough 2015-10-12 20:43:23 UTC
Changing status to Not a Bug as the product is working as designed.


Note You need to log in before you can comment on or make changes to this bug.