Bug 1269264 - Ethernet device changed to 'disconnected' during boot; no network access
Ethernet device changed to 'disconnected' during boot; no network access
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 16:10 EDT by Micah Abbott
Modified: 2015-11-19 05:14 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.55-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 05:14:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Micah Abbott 2015-10-06 16:10:23 EDT
After completing an install using the latest ISO (7.2-2), whereby most defaults were selected, the host is left without an IP address.

During the install, I had used the network spoke to enable networking and the host was assigned an IP address as expected.

After rebooting into the system, the host is left without an IP address.

# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:4d:df:30 brd ff:ff:ff:ff:ff:ff
3: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN 
    link/ether 02:42:f8:60:9f:3a brd ff:ff:ff:ff:ff:ff
    inet 172.17.42.1/16 scope global docker0
       valid_lft forever preferred_lft forever


I looked through the contents of 'journalctl' and found these messages related to the 'ens3' interface:


# journalctl | grep ens3
Oct 06 15:53:24 localhost.localdomain NetworkManager[724]: <info>  ifcfg-rh: new connection /etc/sysconfig/network-scripts/ifcfg-ens3 (6150e941-4d03-42da-88a9-fb2a725b63b1,"ens3")
Oct 06 15:53:24 localhost.localdomain NetworkManager[724]: <info>  (ens3): new Ethernet device (carrier: OFF, driver: 'virtio_net', ifindex: 2)
Oct 06 15:53:24 localhost.localdomain NetworkManager[724]: <info>  (ens3): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Oct 06 15:53:24 localhost.localdomain kernel: IPv6: ADDRCONF(NETDEV_UP): ens3: link is not ready
Oct 06 15:53:24 localhost.localdomain NetworkManager[724]: <info>  (ens3): link connected
Oct 06 15:53:24 localhost.localdomain NetworkManager[724]: <info>  (ens3): device state change: unavailable -> disconnected (reason 'none') [20 30 0]
               

Note, similar behavior was observed when using a KVM environment or bare-metal.

Additionally, when I repeated the install using the 7.2-1 ISO, this problem did not occur.
Comment 2 Micah Abbott 2015-10-06 16:31:30 EDT
It appears that /etc/sysconfig/networking-scripts/ifcfg-ens3 had ONBOOT=no

# cat /etc/sysconfig/network-scripts/ifcfg-ens3 
TYPE=Ethernet
BOOTPROTO=dhcp
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=ens3
UUID=6150e941-4d03-42da-88a9-fb2a725b63b1
DEVICE=ens3
ONBOOT=no


Changing ONBOOT=yes and then 'systemctl restart network' resolved the issue.

However, I don't know why ONBOOT=no was configured that way in the first place.
Comment 3 Micah Abbott 2015-10-06 16:35:13 EDT
The contents of /etc/sysconfig/networking-scripts/ifcfg-ens3 are the same in the 7.2-1 ISO, so I'm not sure what to make of all of this.
Comment 4 Colin Walters 2015-10-06 16:53:58 EDT
I reproduce this too.
Comment 5 Colin Walters 2015-10-07 09:11:54 EDT
I downloaded https://download.eng.rdu2.redhat.com/rel-eng/latest-RHEL-7/compose/Server/x86_64/iso/ and got the same symptom.  I'm assuming this is fallout from the 7.2 installer rebase.
Comment 6 Radek Vykydal 2015-10-07 09:29:36 EDT
I'll look into it.
Comment 7 Radek Vykydal 2015-10-08 07:09:15 EDT
(In reply to Colin Walters from comment #5)
> I downloaded
> https://download.eng.rdu2.redhat.com/rel-eng/latest-RHEL-7/compose/Server/
> x86_64/iso/ and got the same symptom.  I'm assuming this is fallout from the
> 7.2 installer rebase.

Yeah, seems so, in RHEL 7.1 the NIC activated in GUI would have ONBOOT=yes.

https://github.com/rvykydal/anaconda/commit/117c4c17fffdf10fe5a0781d04f633deaab5d611
Comment 8 Radek Vykydal 2015-10-08 07:19:53 EDT
https://github.com/rhinstaller/anaconda/pull/395
Comment 12 errata-xmlrpc 2015-11-19 05:14:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2284.html

Note You need to log in before you can comment on or make changes to this bug.