Bug 1269270 - mate-panel's volume applet is muted by default
mate-panel's volume applet is muted by default
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mate-panel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 16:22 EDT by Giulio 'juliuxpigface'
Modified: 2015-10-07 17:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-07 17:17:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio 'juliuxpigface' 2015-10-06 16:22:28 EDT
Description of problem:
I'm doing release validation testing with a qemu-kvm system installed from the compose "Fedora-Live-MATE_Compiz-x86_64-23-TC1.iso".

By default, the applet from mate-panel is muted. The TestCase "QA:Testcase_audio_basic" states explicitly that "users should not have to adjust any default volume settings in order to hear the sound".


Version-Release number of selected component (if applicable):
mate-panel-1.10.1-1.fc23.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora 23 Mate (Final TC1 Compose).
2. Log in to a Mate session.

Actual results:
mate-panel's volume applet is muted by default.

Expected results:
In accordance to the TestCase cited above, the volume should not be muted by default.

Additional info:
Well, I know that this might be silly and all, but I must follow QA's guidelines. See this for reference: https://fedoraproject.org/wiki/QA:Testcase_audio_basic

I set 'severity' to low since, in my opinion, this is not a big issue.
Comment 1 Wolfgang Ulbrich 2015-10-06 16:28:13 EDT
Is it only muted and you can unmute it?
Or you can't unmute it?
Is pulsaudio running?
Comment 2 Wolfgang Ulbrich 2015-10-07 15:05:03 EDT
I did the installation 2 times from mate-compiz tc1 with virtual-manger qemu-kvm virtualization.
Mate volume applet isn't muted.
Maybe you're a victim of the pulseaudio flat volume bug, see devel mailing list.
I use 'flat-volumes = no' in daemon.conf on my host system.
Please try again and give more debug infos.
Otherwise i will mark this report with 'works for me'.
Comment 3 Giulio 'juliuxpigface' 2015-10-07 16:37:22 EDT
Hi Wolfgang, thank you for your replies and your hints.

(In reply to Wolfgang Ulbrich from comment #2)
> I use 'flat-volumes = no' in daemon.conf on my host system.
> Please try again and give more debug infos.

This does the trick! With this setting, the bug isn't reproducible here too, thanks!

Also, I've tested with a live usb on bare metal and everything is working properly by default.


(In reply to Wolfgang Ulbrich from comment #1)
> Is it only muted and you can unmute it?
> Or you can't unmute it?
> Is pulsaudio running?

Yes, I was able to unmute the applet. Audio was already working fine, anyway, it was only muted by default.
Comment 4 Wolfgang Ulbrich 2015-10-07 17:17:31 EDT
Hi Giulio,
cool that it works.
I don't think it makes sence to re-asign the report to  virtual-manager or pulseaudio, so i will close it.
Feel free to re-open and re-asign the report to culprit component, if you don't agree.

Note You need to log in before you can comment on or make changes to this bug.