Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1269331 - plplot: FTBFS in rawhide
Summary: plplot: FTBFS in rawhide
Keywords:
Status: CLOSED DUPLICATE of bug 1392151
Alias: None
Product: Fedora
Classification: Fedora
Component: plplot
Version: 25
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-07 03:04 UTC by Orion Poplawski
Modified: 2016-11-23 04:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-23 04:50:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Orion Poplawski 2015-10-07 03:04:39 UTC
Description of problem:
Package plplot fails to build from source in rawhide, triggered by cmake 3.4.0-rc1 update.

Previous good 
(cmake 3.3.2):

[ 22%] Building Ada object examples/ada/CMakeFiles/x00a.dir/x00a.o
cd /builddir/build/BUILD/plplot-5.11.1/fedora/examples/ada && 
/usr/bin/gnatgcc 
-I/builddir/build/BUILD/plplot-5.11.1/fedora/examples/ada 
-I/builddir/build/BUILD/plplot-5.11.1/bindings/ada    -c 
/builddir/build/BUILD/plplot-5.11.1/examples/ada/x00a.adb -o 
CMakeFiles/x00a.dir/x00a.o

New bad:

[ 22%] Building Ada object examples/ada/CMakeFiles/x00a.dir/x00a.o
cd /builddir/build/BUILD/plplot-5.11.1/fedora/examples/ada && 
/usr/bin/gnatgcc   -c 
/builddir/build/BUILD/plplot-5.11.1/examples/ada/x00a.adb -o 
CMakeFiles/x00a.dir/x00a.o
x00a.adb:28:05: file "plplot_auxiliary.ads" not found
x00a.adb:29:05: file "plplot_traditional.ads" not found
examples/ada/CMakeFiles/x00a.dir/build.make:65: recipe for target 
'examples/ada/CMakeFiles/x00a.dir/x00a.o' failed

So we're now missing the -I include dir options.

Version-Release number of selected component (if applicable):
5.11.1-1.fc24

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/plplot

Comment 1 Jan Kurik 2016-02-24 15:36:51 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 2 Orion Poplawski 2016-07-19 22:16:53 UTC
New failure now: 

The following tests FAILED:
	 19 - examples_epsqt (Timeout)
	 20 - examples_pdfqt (Timeout)

Comment 3 Jan Kurik 2016-07-26 04:52:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 4 Orion Poplawski 2016-11-23 04:50:37 UTC

*** This bug has been marked as a duplicate of bug 1392151 ***


Note You need to log in before you can comment on or make changes to this bug.