Bug 1269350 - ImportError: No module named awake
ImportError: No module named awake
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: awake (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
: 1278070 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 01:59 EDT by Matthias Runge
Modified: 2016-04-02 04:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-02 04:27:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Replace all the shbangs on the python files (289 bytes, patch)
2016-03-10 13:47 EST, Joel Rivera
no flags Details | Diff

  None (edit)
Description Matthias Runge 2015-10-07 01:59:04 EDT
Description of problem:

[root@sofja ~]# dnf install awake
Last metadata expiration check performed 0:00:00 ago on Wed Oct  7 07:56:32 2015.
Dependencies resolved.
================================================================================
 Package               Arch           Version              Repository      Size
================================================================================
Installing:
 awake                 noarch         1.0-5.fc23           fedora          11 k
 python3-awake         noarch         1.0-5.fc23           fedora          20 k

Transaction Summary
================================================================================
Install  2 Packages

Total download size: 32 k
Installed size: 39 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): awake-1.0-5.fc23.noarch.rpm               46 kB/s |  11 kB     00:00    
(2/2): python3-awake-1.0-5.fc23.noarch.rpm       71 kB/s |  20 kB     00:00    
--------------------------------------------------------------------------------
Total                                           6.5 kB/s |  32 kB     00:04     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : python3-awake-1.0-5.fc23.noarch                             1/2 
  Installing  : awake-1.0-5.fc23.noarch                                     2/2 
  Verifying   : awake-1.0-5.fc23.noarch                                     1/2 
  Verifying   : python3-awake-1.0-5.fc23.noarch                             2/2 

Installed:
  awake.noarch 1.0-5.fc23            python3-awake.noarch 1.0-5.fc23           

Complete!
[root@sofja ~]# aw
awake  awk    
[root@sofja ~]# awake 
Traceback (most recent call last):
  File "/usr/bin/awake", line 2, in <module>
    import awake
ImportError: No module named awake
[root@sofja ~]# 


Version-Release number of selected component (if applicable):
awake.noarch 1.0-5.fc23

How reproducible:
100%

Steps to Reproduce:
1. see above
Comment 1 Juan Orti 2015-10-26 06:09:33 EDT
/usr/bin/awake must use python3 in the shebang
Comment 2 Juan Orti 2015-11-12 04:38:17 EST
Any news?
Comment 3 Fabian Affolter 2015-11-15 05:52:36 EST
*** Bug 1278070 has been marked as a duplicate of this bug. ***
Comment 4 Joel Rivera 2016-03-10 13:47 EST
Created attachment 1135035 [details]
Replace all the shbangs on the python files

Optionally we could just replace the one in src/scripts.

Note You need to log in before you can comment on or make changes to this bug.