Bug 126937 - Desktop locks up with no provocation, can still switch to VT
Desktop locks up with no provocation, can still switch to VT
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-29 10:16 EDT by Dan Reish
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 17:35:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Reish 2004-06-29 10:16:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
(I'm not sure which component caused this problem, of course, or even
what my actual window manager process is under gnome.  I'll describe
as much as I can.)

My entire X desktop locked up a few minutes ago.  Unfortunately, I
don't know what I did just before it locked up (I was moving back and
forth between multiple computers), but it was probably nothing more
than switching windows or virtual desktops.

Symptoms were as follows:

1. First, the pointer was invisible.  I moved the mouse around, trying
to find it, but I could not.

2. Then, I tried to switch between windows with Alt-Tab, thinking that
an app might have blanked out the cursor.  The currently-selected-
window box in the middle of the screen appeared as usual, and the
heavy rectangle around the currently selected window appeared, but
when I released Alt-Tab, the boxes did not go away and the window that
should have been selected (Emacs) did not rise to the top and redraw.

3. All further X input events after that point produced no visible result.

4. Ctrl-Alt-F1 switched to VT 1 successfully.  Switching back showed
the same screen I'd seen before with one notable exception: the
gnome-panel I have at the top of my screen was not visible.  In its
place was garbage data.

5. I switched back to VT 1 and tried kill -HUP <gnome-session pid>,
hoping it might do something reasonable with a SIGHUP like restart the
window manager.  The X server restarted and returned to the login
screen.  Logging in again resulted in the same empty desktop I got
when I first logged in after upgrading from Red Hat 9 to Fedora Core
2.  Aside from that, everything seems to be working as usual.




Version-Release number of selected component (if applicable):
2.6.0-4

How reproducible:
Didn't try

Steps to Reproduce:
1. No clue.  I don't recall doing anything I haven't done a thousand
times before.
    

Actual Results:  Desktop locked up

Expected Results:  Um.  Yeah.  I guess I would expect the desktop not
to lock up.

Additional info:
Comment 1 Matthew Miller 2005-04-26 12:24:51 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 2 Ray Strode [halfline] 2005-05-11 17:35:53 EDT
Hi,

This bug is being closed because it has been in the NEEDINFO state for a long
time now.  Feel free to reopen the bug report if the problem still happens for
you and you can provide any information that was requested.

Note You need to log in before you can comment on or make changes to this bug.