Bug 1269411 - [z-stream clone 3.5.6] [vdsm] SpmStart fails after "offline" upgrade of DC with V1 master domain to 3.5
[z-stream clone 3.5.6] [vdsm] SpmStart fails after "offline" upgrade of DC w...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.1
All Linux
urgent Severity urgent
: ovirt-3.5.6
: 3.5.6
Assigned To: Liron Aravot
Aharon Canan
storage
: Regression, ZStream
Depends On: 1242092
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 05:29 EDT by rhev-integ
Modified: 2016-02-10 13:08 EST (History)
29 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, upgrading a data center with compatibility version of 3.0 (with a V1 master domain) when it's on maintenance to a compatibility version of 3.5 caused the SPM start to fail. The SPM start in the 3.5 host attempted to inquire the cluster lock and since it is not supported, the SPM failed to start. With this update, SPM start won't fail even if the cluster lock inquiring is not supported.
Story Points: ---
Clone Of: 1242092
Environment:
Last Closed: 2015-12-01 15:40:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45680 None DRAFT core: fix spm election after pool upgrade Never
oVirt gerrit 45763 master MERGED core: moving InquireNotSupportedError to storage_exception.py Never
oVirt gerrit 45764 master MERGED sp: startSpm - clusterlock inquire leads to failure Never
oVirt gerrit 45929 master MERGED JsonRpcVdsServer: spmStart() to pass the needed domain version Never
oVirt gerrit 45930 master MERGED core: spmStart failure when clusterlock inquire isn't supported Never
oVirt gerrit 45965 ovirt-3.6 MERGED core: moving InquireNotSupportedError to storage_exception.py Never
oVirt gerrit 45966 ovirt-3.6 MERGED sp: startSpm - clusterlock inquire leads to failure Never
oVirt gerrit 45975 ovirt-3.5 MERGED core: moving InquireNotSupportedError to storage_exception.py Never
oVirt gerrit 45976 ovirt-3.5 MERGED sp: startSpm - clusterlock inquire leads to failure Never
oVirt gerrit 46019 ovirt-engine-3.6 MERGED JsonRpcVdsServer: spmStart() to pass the needed domain version Never
oVirt gerrit 46020 ovirt-engine-3.6 MERGED core: spmStart failure when clusterlock inquire isn't supported Never
oVirt gerrit 46027 ovirt-engine-3.5 MERGED JsonRpcVdsServer: spmStart() to pass the needed domain version Never
oVirt gerrit 46028 ovirt-engine-3.5 MERGED core: spmStart failure when clusterlock inquire isn't supported Never

  None (edit)
Comment 2 Allon Mureinik 2015-10-26 09:41:12 EDT
Liron, please provide some doctext on when this BZ fixes.
Comment 4 Aharon Canan 2015-11-08 07:24:00 EST
Can you please add verification steps? 

Following comment by laravot@redhat.com on August 30 at 16:09:00, 2015
You wrote that there are multiple issues and I am not sure for what issue this bug stands for.
Comment 5 Liron Aravot 2015-11-09 07:45:28 EST
Aharon, 
1. create a v3.0 dc, add a 3.5 host to it, add a domain..wait for the spm to start.
2. put the dc to maintenance.
3. upgrade the dc to 3.5
4. activate the dc
5. verify that spm start succesfully.

you can also test the scenario of the original bug.

thanks,
Liron.
Comment 6 Aharon Canan 2015-11-09 09:37:51 EST
(In reply to Liron Aravot from comment #5)
> Aharon, 
> 1. create a v3.0 dc, add a 3.5 host to it, add a domain..wait for the spm to
> start.
> 2. put the dc to maintenance.
> 3. upgrade the dc to 3.5
> 4. activate the dc
> 5. verify that spm start succesfully.
> 
> you can also test the scenario of the original bug.
> 
> thanks,
> Liron.

Verified using vt18.2
Comment 7 Julie 2015-11-11 00:23:57 EST
Hi Liron,  
I'm not sure if I fully understand this bug. I have updated the doc text. Please let me know if you have any feedback.

Cheers,
Julie
Comment 8 Liron Aravot 2015-11-16 09:09:48 EST
Hi Julie,
I've updated the doc text.
Comment 9 Julie 2015-11-16 17:59:19 EST
(In reply to Liron Aravot from comment #8)
> Hi Julie,
> I've updated the doc text.

Thanks!
Comment 11 errata-xmlrpc 2015-12-01 15:40:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2530.html

Note You need to log in before you can comment on or make changes to this bug.