Bug 1269415 - Text overlap observed on storage->general sub-tab
Text overlap observed on storage->general sub-tab
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
All Linux
medium Severity medium
: ovirt-3.6.1
: 3.6.0
Assigned To: Alexander Wels
Aharon Canan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 05:40 EDT by Bhushan Barve
Modified: 2016-03-10 01:55 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 01:55:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text_overlap storage sub-tab (101.60 KB, image/png)
2015-10-07 05:41 EDT, Bhushan Barve
no flags Details
general sub-tab storage (48.91 KB, image/png)
2015-10-08 13:27 EDT, Daniel Erez
no flags Details
Wrapping labels (129.95 KB, image/png)
2015-10-14 09:44 EDT, Alexander Wels
no flags Details
screenshot (97.04 KB, image/png)
2015-12-29 04:36 EST, Aharon Canan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47334 master MERGED webadmin: Wrap GeneralFormPanel labels Never
oVirt gerrit 47484 ovirt-engine-3.6 MERGED webadmin: Wrap GeneralFormPanel labels Never
oVirt gerrit 47598 master MERGED webadmin: Wrap GeneralFormValue labels Never
oVirt gerrit 47913 ovirt-engine-3.6 MERGED webadmin: Wrap GeneralFormValue labels Never

  None (edit)
Description Bhushan Barve 2015-10-07 05:40:34 EDT
Description of problem: Text overlap is observed on  storage->general sub-tab for "Critical Space Action Blocker" string. Please refer attached screenshot.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager バージョン: 3.6.0-0.16.master.el6

How reproducible:
always

Steps to Reproduce:
1.login to rhevm with ja_JP locale
2.Go to storage->general sub-tab
3.Observe "Critical Space Action Blocker"

Actual results:
Text overlap is seen.

Expected results:
Text overlap should not be there.

Additional info:
Comment 1 Bhushan Barve 2015-10-07 05:41 EDT
Created attachment 1080563 [details]
text_overlap storage sub-tab
Comment 2 Daniel Erez 2015-10-08 13:27 EDT
Created attachment 1081061 [details]
general sub-tab storage
Comment 3 Daniel Erez 2015-10-08 13:32:14 EDT
Hi Alex,

Seems that the issue is reproduced only on resolutions lower than 1920px (width) - see attached screenshots. Can it be tuned in the bootstrap grids infrastructure of GeneralFormPanel?

Thanks,
Daniel
Comment 4 Alexander Wels 2015-10-08 13:39:51 EDT
Daniel,

Each column in the grid gets a certain percentage allocated to it. This is percentage based. Normally what happens if the text is too big like that it is supposed to wrap on white space or something similar.

Its easy to give the label more space, but then you take space away from the actual content. And I have already gotten complaints about not having enough space for the content. So without the text wrapping I am not 100% sure what to do. I suppose we could add some css directives to force a wrap.
Comment 5 Daniel Erez 2015-10-08 14:05:07 EDT
(In reply to Alexander Wels from comment #4)
> Daniel,
> 
> Each column in the grid gets a certain percentage allocated to it. This is
> percentage based. Normally what happens if the text is too big like that it
> is supposed to wrap on white space or something similar.
> 
> Its easy to give the label more space, but then you take space away from the
> actual content. And I have already gotten complaints about not having enough
> space for the content. So without the text wrapping I am not 100% sure what
> to do. I suppose we could add some css directives to force a wrap.

Maybe we can at least add more space to the label just when the grid has a single column? Do we have an RFE/BZ to track it?
Comment 6 Daniel Erez 2015-10-08 16:20:37 EDT
Seems it should be covered by bug 1205309 ?
Comment 7 Einav Cohen 2015-10-08 17:24:50 EDT
the complaint here is about the overlap between the field-name and the field value. 

when resolution is low / window is re-sized to a small size, the labels should be cropped accordingly (based on their granted width percentage) and not overlap each other (see http://i.imgur.com/Xr8qSJb.png). 

[once label is / will be cropped, we would like to display a tool-tip for it with its full text upon hover - that's what bug 1205309 is tracking]. 

problem exists in all locales, including English [again, see http://i.imgur.com/Xr8qSJb.png] -> removed 'ja-jp' prefix from BZ summary, i18n keyword.

re-assigning to Alexander (fix should be very similar to the one done for bug 1252987, IIUC).
Comment 8 Alexander Wels 2015-10-13 10:40:38 EDT
So I have a bit of a problem, if I make the label width wider, I end up with bz1230723. If I don't I end up with this. I checked and I have to make my screen about half of 1920 pixels for it to overlap. Personally I think this is the lesser of the two evils.

@Einav,
What do you want me to pick for brokenness? this one or bz1230723?
Comment 9 Einav Cohen 2015-10-13 16:53:02 EDT
(In reply to Alexander Wels from comment #8)
> So I have a bit of a problem, if I make the label width wider, I end up with
> bz1230723. If I don't I end up with this. I checked and I have to make my
> screen about half of 1920 pixels for it to overlap. Personally I think this
> is the lesser of the two evils.
> 
> @Einav,
> What do you want me to pick for brokenness? this one or bz1230723?

just to make sure that we are completely in sync with regards to the current state / problem / suggested solution: looking at the sub tab, it seems that "Warning Low Space Indicator" label is being *properly* cropped, whereas the "Critical Space Action Blocker" label is not cropped and overlapping with the value-label [see http://i.imgur.com/Xr8qSJb.png]. so I am not sure which label should be made wider; shouldn't all the labels be in the exact same width? or actually - shouldn't all the labels be in the exact same "column"-scope within the bootstrap grid? 

what I would like to do is to make the "Critical Space Action Blocker" label be cropped exactly like the "Warning Low Space Indicator" label is being cropped - they should have the exact same length, be cropped at exactly the same point if they don't have enough real-estate to be fully displayed, etc. 

see http://i.imgur.com/wSkSFnH.png for clarification. 

I don't mind that the labels are being cropped - that's an expected behaviour when there is not enough real-estate to render everything (and probably more acceptable than overlapping). 
We will need to make sure at some point that labels with cropped text have tool-tips that display the full text upon hover - but that's out of scope for this BZ (it is tracked via bug 1205309) - for now, let's make sure that the "Critical Space Action Blocker" label is being cropped exactly like the "Warning Low Space Indicator" label above it, rather than overlap the value. 

I hope this is clear, if it's not - I apologize, feel free to 'needinfo' me again if necessary.
Comment 10 Alexander Wels 2015-10-14 09:44 EDT
Created attachment 1082833 [details]
Wrapping labels
Comment 11 Alexander Wels 2015-10-14 09:49:02 EDT
@Einav,

One is being cropped while the other is not because one is being rendered as an input while the other is being rendered as a span. Apparently the input doesn't allow the overlapping while the span does. While investigating the difference I noticed we are specifically forcing the labels to not wrap. In a dynamic column layout like the bootstrap grids this makes no sense, it might have made sense in the table layout we had before, but not anymore.

I have attached a screen shot of the wrapping labels, which IMO is a much better solution than simply cutting off part of the label. I have tested this with a variety of General tabs and they all look good to me.

Is this acceptable instead of cropping the label?
Comment 12 Einav Cohen 2015-10-14 13:18:07 EDT
(In reply to Alexander Wels from comment #11)
> @Einav,
> 
> One is being cropped while the other is not because one is being rendered as
> an input while the other is being rendered as a span. Apparently the input
> doesn't allow the overlapping while the span does. While investigating the
> difference I noticed we are specifically forcing the labels to not wrap. In
> a dynamic column layout like the bootstrap grids this makes no sense, it
> might have made sense in the table layout we had before, but not anymore.
> 
> I have attached a screen shot of the wrapping labels, which IMO is a much
> better solution than simply cutting off part of the label. I have tested
> this with a variety of General tabs and they all look good to me.
> 
> Is this acceptable instead of cropping the label?

yes, that's a great idea actually, as it would spare us from dealing with bug 1205309 (if label-texts are never cropped, we don't need to take care of supporting full-text-tool-tips-upon-hover for them). 

many thanks, Alexander.
Comment 13 Aharon Canan 2015-12-29 04:36 EST
Created attachment 1110134 [details]
screenshot

Verified (rhevm-3.6.2-0.1.el6.noarch)
Comment 14 Allon Mureinik 2016-03-10 01:55:08 EST
RHEV 3.6.0 has been released, setting status to CLOSED

Note You need to log in before you can comment on or make changes to this bug.