Bug 1269512 - sss_override: memory violation
sss_override: memory violation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: SSSD Maintainers
Steeve Goveas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 09:07 EDT by Pavel Březina
Modified: 2016-11-04 03:12 EDT (History)
9 users (show)

See Also:
Fixed In Version: sssd-1.14.0-0.1.alpha.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 03:12:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Březina 2015-10-07 09:07:13 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/2826

We are accessing freed memory when working with user-export and group-export.
Comment 2 Mike McCune 2016-03-28 19:36:13 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Dan Lavu 2016-09-19 15:25:55 EDT
Verified against sssd-client-1.14.0-42.el7.x86_64

[root@dell-per230-02 ~]# sss_override  user-add  -n admin Administrator@sssdad2012r2.com 
SSSD needs to be restarted for the changes to take effect.
[root@dell-per230-02 ~]# service sssd restart

[root@dell-per230-02 ~]# sss_override  user-export users

[root@dell-per230-02 ~]# cat users
Administrator@sssdad2012r2.com:admin::::::

[root@dell-per230-02 ~]# sss_override -n group-add -n sssd "domain users@sssdad2012r2.com" 

[root@dell-per230-02 ~]# sss_override group-export group

[root@dell-per230-02 ~]# cat group 
Domain Users@sssdad2012r2.com:sssd:
Comment 8 errata-xmlrpc 2016-11-04 03:12:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2476.html

Note You need to log in before you can comment on or make changes to this bug.