Bug 1269601 - wrong handling of filename '\' on vboxsf
wrong handling of filename '\' on vboxsf
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: findutils (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Kamil Dudka
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 12:50 EDT by Ondřej Pták
Modified: 2015-10-26 07:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 07:39:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondřej Pták 2015-10-07 12:50:22 EDT
Description of problem:
File '\' is listed 2038 times on vboxsf filesystem, each time longer

Version-Release number of selected component (if applicable):
findutils-4.5.11-3.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. setup shared dirrectory in virtualbox and set working dirrectory to it
2. mkdir test && touch test/\\ && cd test
3. find .

Actual results:
.
./\
./\/\
./\/\/\
./\/\/\/\
./\/\/\/\/\
./\/\/\/\/\/\
(...)

Expected results:
.
./\

Additional info:
* the same problem is in findutils-4.4.2-6.el6
* works correctly on xfs, ext4, msdos, vfat, cifs
* other tools like ls, git, file, ln   has no problem with this filename
Comment 2 Kamil Dudka 2015-10-08 11:09:17 EDT
(In reply to Ondřej Pták from comment #0)
> Steps to Reproduce:
> 1. setup shared dirrectory in virtualbox and set working dirrectory to it

Could you please elaborate on the above step?

Are there any RHEL/EPEL packages I need to install?

What commands should I run to setup the shared directory?
Comment 3 Ondřej Pták 2015-10-09 04:24:04 EDT
Sure I can. Here is more detailed explanation of step 1:
a) install Virtualbox https://www.virtualbox.org/wiki/Downloads
b) create VM in Virtualbox
c) install rhel-7 into that VM
d) install guest additions (needs for shared directory support, error in installing graphical driver can be ignored)
e) setup shared directory (MenuPanel:Devices->Shared Folder Settings)
f) reboot (I'm not sure if this is necessary)
e) now shared directory from host OS should be available in VM system, which looks like this:
#mount
(...)
none on /media/sf_autogit type vboxsf (rw,nodev,relatime)
Comment 4 Ondřej Pták 2015-10-09 04:25:31 EDT
I forgot to add link to instructions for d), here it is: http://linuxconfig.org/rhel-7-virtualbox-guest-additions-installation
Comment 5 Ondřej Pták 2015-10-09 04:43:05 EDT
I just tried all these steps and found 1 error.
step 2.: for some reason I'm unable to create file \ from VM, but I can create it in host VM
Comment 6 Kamil Dudka 2015-10-09 12:21:54 EDT
I have followed the above steps but find worked as expected.  It must have been something specific to your configuration.  Note that I was able to create a file named '\' from my RHEL-7 VM just fine.  In any case, this does not seem to be a bug of findutils.
Comment 8 Ondřej Pták 2015-10-26 07:39:30 EDT
Sorry for delay, I was too busy lately. Finally I found time for setting clean environment (reinstalled VirtualBox, newly created VM). This issue doesn't occurs with the same version of findutils, so the cause of this issue is somewhere else, probably filesystem kernel module or anything other broken on my environment.

Note You need to log in before you can comment on or make changes to this bug.